Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Gallery - can't rearrange images or add descriptions


Recommended Posts

Does anyone else have this issue? Dragging the images around is very touch-and-go for me. I usually have to add the images in one round, then refresh the page, open the edit again, and sometimes I'll be able to rearrange them with drag-and-drop.

Additionally, when I add a description and a link and save the page, it saves the changes maybe 50% of the time.

See attached video.

I've tried in Chrome, Safari and Firefox - all of them have the same issues. I've also tried in private / incognito windows to rule out browser cache or cookie issues.

I'm not sure if this is the right place to report this. I'm building a website for a client and I have A LOT (hundreds) of images and galleries.

Link to comment

Yes I have this exact issue. First it alerted me that my pngs were too large so I downsized them....which helped but didn't get rid of the issue entirely. Also, I'm with you...there's a place for a "description" but it doesn't populate anything right now -- specifically in the lightbox, or anywhere else: hover, etc.

Link to comment
  • 2 weeks later...
On 5/16/2020 at 10:28 AM, artgirl81 said:

Yes I have this exact issue. First it alerted me that my pngs were too large so I downsized them....which helped but didn't get rid of the issue entirely. Also, I'm with you...there's a place for a "description" but it doesn't populate anything right now -- specifically in the lightbox, or anywhere else: hover, etc.

SS just updated gallery caption yesterday. You can try again ;) ✌️

Email me if you have need any help (free, of course.). Answer within 24 hours.

How to: Setup password & share url - Insert Custom CSS - Page Header - Upload Custom Font - Upload File - Find Block ID - Contact Customer Care

Link to comment
On 5/27/2020 at 2:44 AM, tuanphan said:

SS just updated gallery caption yesterday. You can try again ;)

It's still incredibly buggy for me.

  • Drag and Drop doesn't work
  • Updating description doesn't work (I'm using a hack to show the description below the image, and it works IF the description is saved, but it rarely is)
  • When uploading multiple images, a few of them are blank after uploading

I'm really starting to regret my decision to use SS... I literally can't do my job. Will not recommend to anyone in the future

Link to comment

My current workaround is to install this paid plugin from a third-party to bring Gallery Blocks back to pages: https://www.squarewebsites.org/products/squarespace-admin-ui-tweaks

The Gallery Blocks work SO much better. You can add title and descriptions, upload is consistent and drag-n-drop works flawlessly. I think Squarespace should just bring back Gallery Blocks to pages. The Gallery Sections in 7.1 are just way too buggy.

Link to comment
  • 1 year later...

Its literally faster for me to delete all my images and re upload them in the exact order I want, it just wont let me rearrange at all i move one and the rest get shuffled. It's driving me crazy. I'm going to put a ticket it to let them know but it probably wont be fixed any time soon.

7.1 has grown on me but so many things make the work flow sooo unbelievably slow its frustrating.

Link to comment
  • 4 weeks later...
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...