Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Ad7am

Member
  • Content Count

    8
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. For anyone else who needs this, my friend Jason solved it by adding jquery and then disabling touchmove and touchstart. So in addition to adding the custom CSS above, go to Settings > Advanced > Code Injection > Footer and add: <script src="https://code.jquery.com/jquery-3.5.1.min.js" integrity="sha256-9/aliU8dGd2tb6OSsuzixeV4y/faTqgFtohetphbbj0=" crossorigin="anonymous"> </script> <script> $(document).ready(function() { $("div.gallery-lightbox-list").bind('touchmove', function( event ) { event.stopImmediatePropagation(); }); $("
  2. Site URL: http://bit.ly/ad7am-test1 EDIT 10/26/2020: Solved! See answer below. The webpage I’m trying to diagnose this on is http://bit.ly/ad7am-test1 and the password is < helper >. The default behavior for the gallery is that clicking or touching an image brings up a lightbox, to show the image at the largest it fits in the window, e.g. at 100% of the height of the viewport. I've customized the CSS — because I need viewers to be able to read the text — so that the lightbox instead shows the image at 100% of the width of the viewport.
  3. Thanks for asking, Tuan. I emailed you, and will do so again. Nope, on mobile I still can't get the long images to show in the lightbox at full width without cutting off at the bottom — there's no scrollbar. It seems “overflow-y: auto !important;” is being overruled somewhere.
  4. Here's how to make it larger: .gallery-lightbox-close-btn-icon { transform: scale(2, 2); } You can also do something like this: .gallery-lightbox-close-btn-icon { transform: scale(2, 2); transition: 1s; } .gallery-lightbox-close-btn-icon:hover { transform: rotate(270deg) scale(4, 4); }
  5. Solved my own question of how to my enable lightbox images to show at their full width, no matter the height. Here's the CSS: .gallery-lightbox-item[data-active='true'] { height: auto !important; } .gallery-lightbox-list { overflow-x: hidden; overflow-y: auto !important; z-index: 100; } That puts the scrollbar in the correct place, and keeps the arrows outside the image, where they should be. HOWEVER... I just noticed that on mobile the images are still cut off at the bottom of the lightbox. So it seems the overflow-y property does not work on mobile, though it works fine
  6. Hi Bangan, I want to enable images in gallery lightboxes to show at their full width (no matter the height), so I used this code: .gallery-lightbox-item { height: auto !important; } .gallery-lightbox-wrapper { overflow-x: hidden; overflow-y: auto; } This works, with one issue: The scroll bar is outside the <Next> arrow. I tried substituting .gallery-lightbox-wrapper with each of these other IDs I found in the page source: .gallery-lightbox-wrapper .gallery-lightbox-item-wrapper .gallery-lightbox-item .gallery-lightbox-list .gallery
  7. Thanks for posting this list, Tuanphan. For gallery lightboxes, I've found the following IDs: .gallery-lightbox-wrapper .gallery-lightbox-item-wrapper .gallery-lightbox-item .gallery-lightbox-list .gallery-lightbox-item-src .gallery-lightbox-item-img I wanted to enable my gallery images to show at their full width (no matter the height), so I used this code: .gallery-lightbox-item { height: auto !important; } .gallery-lightbox-wrapper { overflow-x: hidden; overflow-y: auto; } It works, with one issue: The scroll bar is outside the &
×
×
  • Create New...