Jump to content

Help! Blog category URL not working

Go to solution Solved by paul2009,

Recommended Posts

Site URL: https://www.warm-me-up.com/blog/category/Revitalising+your+repertoire

Hi there, we had a user reach out to us who noticed that the Blog category URL they had was broken.

https://www.warm-me-up.com/blog/category/Revitalising+your+repertoire

I noticed the only difference between theirs and the one I can see if I navigate to the page is they have no capital 'R' for 'Revitalising' and mine does. If I replace the 'R' to a 'r', I also get an error message. My understanding is a URL shouldn't be affected by capitalisation? Does Squarespace do an exact match of text when it filters the categories? Is there an easy way to avoid this being a problem? Many thanks in advance for any tips/info/advice!

Link to comment
  • 1 month later...

Did you find an answer to this? I have the same issue - Blog Category links are not working, they actually return the user to the main blog page without filtering to a category. Categories and their links are case sensitive with Squarespace and I have checked these and they are written the same. Be great if you could share an answer if you found one. 

 

Frances O’Reilly  www.theutility.studio  zLfPa_3bXrJVjjG2D9NJjWsyDYITGq-AQ4pLSfcsuwHgc1FJgbmT8EuoAx53oIpicbIZXX92DLMzsg5XW4UJHqR2UdKAM49cEvG5eVqoIit3qvfqN_3WWP1ZPkDVrntsjb6zpg4a5PtGb4Av0g  PVvO1XXM2rZxDMx8nqZFfuT0Y6ZBDtbItk8lPnd_clxdRf0-60lB9djfLd-ptwxxqfen9le_mOh52G4e1geR627H46GZNLbYTcK-J8PGtgHf4JTBqXrismbjFWHM6NG0x6oPYa8waUOsKztkVg  higZyEQ7dWl3HT3k5f7QZyAq1OkO6Aoo5tYGkIw8x7LFUwjovTNvWOrRkDZ5scTDRP1tzvvQiAqDi1wiNvtwbH4nn8UZ5X6T7dBszJGVFch2mFHgX_9BsFvBrFozZcGcFb3GKpOJlijApl9uvQ

 
Link to comment
  • Solution
10 minutes ago, fhoreilly said:

Blog Category links are not working, they actually return the user to the main blog page without filtering to a category.

Have you tried using /blog?category=mycategory where "blog" is the url of the blog page and "mycategory" is the category name?

Improve your online store with our extensions.
About: Sqsp Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Expert and founder of SF Digital, dedicated to improving websites by building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Link to comment
  • 5 weeks later...
  • 3 months later...
On 5/10/2022 at 9:18 AM, paul2009 said:

Have you tried using /blog?category=mycategory where "blog" is the url of the blog page and "mycategory" is the category name?

@paul2009 hi! Can you help me troubleshoot a clients site, it's on 7.0 sqsp. Your URL correction works for them, however, I can't find how to adjust the URL. 

This is the link to their blog and you'll see it does not work when you click the sidebar categories. But when I replace the URL in my browser like you said to do, it works. But how can I edit the actual links within the site so that when you click the link in the sidebar? I've tried going into the settings of the blogs themselves, the settings of the entire site, then blogging and the post url format - but it only covers the blog link, not category links. I've gotten so used to 7.1 already that I'm forgetting how to navigate 7.0! 

I appreciate your help!

Link to comment

First off, check  your blog post settings, and make sure the category is displayed  at the bottom of edit post. You only need to check one post for each category. If it is you may need to reinstall the side bar archive block. You do have one category that works now, Feeding Relationships. Looking at that post should give you a clue as to why the others don't work. It is possible that if you changed posts urls after creating the dropdown that it did not update and can't find the pages. Reinstalling will correct that. 

Edited by derricksrandomviews
Link to comment
13 hours ago, anortherndesign said:

You'll see it does not work when you click the sidebar categories. But when I replace the URL in my browser like you said to do, it works. But how can I edit the actual links within the site so that when you click the link in the sidebar?

The links in the sidebar were created automatically in the Archive Block and should work. 

It looks like a technical fault but I wasn't able to reproduce it on another site so, as a first step, I recommend that you delete the Archive Block and add a new one using the same settings. It may be wise to note the block's Design settings before deleting the block.

When you've replaced the block and saved the changes to the page, check if the links work correctly. If they don't then I recommend getting in touch with Squarespace Customer Care directly.

Let us know how you get on.

Edited by paul2009

Improve your online store with our extensions.
About: Sqsp Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Expert and founder of SF Digital, dedicated to improving websites by building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.