Jump to content

API issues

Go to solution Solved by Matt_Shepherd,

Recommended Posts

Is anyone else seeing issues appear recently with API integrations?

We are seeing problems with order creation. Initially the API started rejecting orders where any line item had unlimited stock set to true but stock level was 0 (0 stock shouldn't matter the product is set to unlimited). And now it has just started rejecting all order creation with the error AUTHORIZATION_ERROR. This is with API keys that have worked fine for over a year now, as well as new keys I have generated for testing which have order read and write permissions.

I have flagged this with support who say they have raised it with the engineering team, but no response other than that so I have no idea how long this is going to be an issue for.

Edited by Matt_Shepherd
Link to comment
58 minutes ago, Matt_Shepherd said:

For anyone interested: support has got back to me saying the endpoint has been locked down for security reasons.

Is this only affecting posts to create orders for you? I ask because I am not experiencing any issues getting orders via the API.

About me: I'm Paul. A SQSP User for 18 yrs, I joined Circle when it launched in 2016 and have been a Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL, providing expertise and extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is free. You can thank me by clicking one of the feedback emojis below. Coffee fuels my work.

Book paid help with a Squarespace Domain

Link to comment

Just to also add we are experiencing the same issue with order creation. It's happening across a number of independent sites. No change on our side. We've retried recycling API keys. It looks like order creation is failing across all SquareSpace stores for us. 

We've replicated by just trying to place via a CURL request to eliminate the possibility of a code regression and it still occurs. Even with full permissions on the API key. 

It's causing significant disruption to our merchants. 
 

{
    "type": "AUTHORIZATION_ERROR",
    "details": null,
    "message": "You are not authorized to do that.",
    "subtype": null,
    "contextId": "EGRESNIEPLIZAUSQUEYQ"
}

 

Link to comment

Is there any update on this? I just spent the past hour and half debugging why my authorization is suddenly not working only to find that others are having the issue. 

How does Squarespace lock down this endpoint and now tell anyone? This is crazy to me. Also causing significant disruption.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.