Jump to content

wrong picture on link

Recommended Posts

I just completely rebranded my website and when I go to it everything looks right but if I copy the url and send it to someone the link that pops up has my old logo image. I have attached picture below of my current website and a picture of what happens when I send a link to it. The photograph of the dog used to be our logo but I have changed it everywhere and cannot figure out what is happening.

IMG_1719.PNG

IMG_1720.PNG

Link to comment

You can change this image in Design > Social Sharing. Click REPLACE and upload a new one 🙂.

When you add a social sharing image, Squarespace adds something called an Open Graph meta tag. It's a small snippet of code that asks third parties to preview the specified image when you share a link to your website.

Currently, your site is using the full colour image shown in your screenshot (shown below for reference):

image.thumb.png.b9496d3801ff4a323c8a24b633a106ef.png

<meta property="og:image" content="http://static1.squarespace.com/static/6081e58df881380ea896446d/t/608da450bc3dfe7e98e0d4e7/1619895388509/99544663-5E1E-47F9-ACA8-7ECA5539AF5B.jpg?format=1500w"/>

Did this help? Please give feedback by clicking an icon below  ⬇️

About me: I'm Paul, a SQSP user for over 18 yrs and a Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL, providing high quality original extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is completely free. You can thank me by selecting a feedback emoji below. Buying a coffee is optional.

Book paid help with domains: Connect a GoDaddy domain. Connect a Squarespace Domain. Domain assistance

Link to comment
3 hours ago, storylaine said:

934C1D30-9A0E-46A4-AC19-03D2DA7225EC.png

95796F11-02B9-48E4-BD6A-FB294EAE68D6.png

You'll have to force facebook to reindex/rescrape your site. It's a common problem and I've heard about it a lot this week. Go to this link and enter your URL and hit debug. May take a bit but it should work. https://developers.facebook.com/tools/debug/

Link to comment
  • 9 months later...
  • 1 month later...

I have this problem currently using Linkedin, that it is posting an old image. I have deleted this image from the asset library in fact, and everything looks good in the Homepage social options. The image should no longer say GRAV in the top right corner. See here:

image.thumb.png.ae40c155e9ecaa40db47802c9deba626.png

But this is showing. I have deleted my cache and tried again, so it's somewhere on the site I guess...

image.png.0f9440dbfc41b82e3865458760ce2e40.png

image.png

Link to comment
  • 5 weeks later...
  • 3 weeks later...
  • 2 months later...

Just got off of chat with Squarespace: here is how you fix the social image

 

Thanks for your patience. So I'm seeing that the image in your text message is on your homepage's social sharing settings. To change this, click Website > Pages > Hover over your homepage > Click the settings icon > Select the Social Sharing Tab > Click remove image > Add a new image. For your reference, here's a screenshot of this on your site:

https://share.squarespace.com/xQuoDd5R

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.