Jump to content

Preview images for blog posts not showing up

Recommended Posts

I'm not quite sure what happened, but all of a sudden the preview images for my blog posts are not showing up. On the "Blog" page, the preview pictures are no longer there for my blog posts, just the title. They were there as of yesterday - what is going on?  Any ideas? Thanks in advance!

Adventureswithheather.com

Link to comment
  • Replies 9
  • Views 8.2k
  • Created
  • Last Reply

Top Posters In This Topic

  • 5 months later...
  • 5 months later...
  • 1 year later...

I'm having the same issue, blogs used to stack up with the full blog and images and now no images, just an excerpt and a 'Read More' link. None of these suggestions work. This is new. Using Forte template. Past blog posts show up fully, no 'Read More' link.

There is no toggle for images in Blog in Site Styles. Is this a premium feature? It also doesn't call it 'Blog List', just 'Blog' and it lists the only options as Show Author Name, Sidebar Position & Width.

Making post Featured doesn't affect it.

Adding an thumbnail image did not make the blog and images show.

SOLUTION FOUND: After fiddling around with it for about an hour and trying all kinds of variations, I just discovered that by placing specific text in the Exceprt section of Options under Edit Post is what appears to be making the blog show just the excerpt. By removing all text in that section, my blog posts not show up on my main page in full, with images.

Link to comment
  • 1 month later...
  • 8 months later...
On 1/6/2022 at 8:28 AM, JDWAtlanta said:

 insert your image somewhere in the verbiage. It'll show when people read your blog page

My issue is that I want only the thumbnail to show, not all the other images I add in a blog post.

Link to comment
  • 2 months later...

Hi everyone, 

I think I may have figured it out. I had some of my posts showing images, and some not. After days of frustration and trial/error, I found that a photo will only show if you have an image as the first thing in your blog post BEFORE adding any text/additional items. 

This means that if you have any text opening your blog posts, you will need to move the image you want featured above that. Then, you’ll add your excerpt text, and all other photos will hide under the “read more” link. 

It’s definitely frustrating to have to go back and move things around, but that seemed to fix my issues. 
 

I do wish there were a way for us to manually add where we want the excerpt to land within the formatting of the blog so we could display more than one image with the excerpt, but I’ll settle for this fix.  

I hope this helps everyone else! 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.