Jump to content

How to enable Squarespace buttons to be clicked once, not twice, to work?

Recommended Posts

A client reported a bug on our site where they had to click twice for any given button to work.

I was able to replicate the bug about 50% of the time on mobile. Sometimes I would need to click twice. Other times not. It happens usually the first time the site is loaded on Chrome, Firefox, and Safari. Didn't seem to matter which button size.

I looked around and was not able to find much other than something about "Turning Off Animations" but as I am on 7.0 I do not see anything like that.

Is this a known issue and are there any work arounds?

Obviously it is an understatement as to how incredibly important it is that the "Request a Quote" button works the first time, every time, all the time, and I am willing to do anything digging to smooth this out.

Thank you for any tips!

Link to comment

I'm thinking the curse of Ajax Loading strikes again! Try, temporarily, turning off Ajax Loading to see if the problem goes away.

Please note that turning off Ajax Loading will effect the performance of your site. Ajax Loading is designed to increase the loading speed of your site after it first loads.

If the problem goes away then it is likely the code has not been written to be Ajax compatible. It would need to be rewritten to be Ajax compatible, assuming it it even possible.

You have to decide whether the custom code you are trying to use is worth turning off Ajax Loading. Or, it is worth trying to get an Ajax compatible version of the code.

@paul2009 has a great article on the ins and outs of Ajax Loading. Please see Why does Squarespace code only work on refresh?

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment
  • 7 months later...

Hello there,

I had the same issue, no links or buttons were working on first click on mobile browsers.

I just turned off all site animations and it finally works. You can disable animations from the "site styles" menu at the upper right corner (brush icon). Hope there is a fix soon

Link to comment
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.