Jump to content

POST Request Working Locally But Not On Web

Recommended Posts

Hi there,

I built an app that helps automate tasks for merchants. Oddly, when I run my app locally and on the web, I can make successful POST requests to the products endpoint. However, only when I run the app locally does my demo Squarespace account reflect the product updates I push. If I follow the same action on web, there is no change. I’m not tripping any CORS issues, nor do I have any errors in terminal or console. Is there a permission step I’m missing somewhere? The API key I’m using for both should have read/write access to the products. Any ideas are super helpful. Thanks!



Link to comment
  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.