Jump to content

Weird sidebar appearing on home page

Recommended Posts

Hi all - appreciate your help!

I've got a strange yellow sidebar that appears on the righthand side of my homepage and I don't know how to get rid of it.

I did add some custom code into the hero module to get that text animation effect, and I think it messed with the properties of the whole page.

 

Would love any thoughts on how to fix it. Thanks!

Link to comment
  • Replies 4
  • Views 382
  • Created
  • Last Reply

Top Posters In This Topic

Please see the following.

Please post the URL for a page on your site where we can see your issue.

If your site is not public please set up a site-wide password, if you've not already done so.

Post the password here.

Adding a site-wide password does not allow anyone to alter your site. It only allows those with the password to see your site. Please read the documentation at the link provided to understand how it works.

Please read the documentation at the link provided on how to share a link to your site to understand how it works. A link to the backend of the your site won’t work for us, i.e. a url that contains /config/.

We can then take a look at your issue.

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment

Good news! Your site does not have the usual issue of content overflowing and causing unwanted borders.

The following code, which I think is in Page Settings > Advanced > Page Header Code Injection for the page, is causing the issue. Remove it.

.container {display: flex;font: black;

Let us know how it goes.

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment

@creedon thanks for trying to help me troubleshoot this!

So I went to that Header Code injection setting, but it's actually blank. 

I did, however, take a look at the html code I'd used for the text animation, and saw that this ".container" line was in there.  So I removed that from the code, and sure enough...it did remove that border!! 

BUT it also made my "Let's talk" button jump up and down with the animated text every time the text types on and off. Which is not great. 

Any other thoughts? 

I could attach screenshots of the code if that would help.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.