Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Help. The "edit site header" button on my home page is not working. I can hover over the button and view it, but clicking it does nothing. I have tried opening squarespace in different browsers and hasn't helped. Any ideas?

Recommended Posts

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Your site is private. Please set up a site-wide password.

Post the password here.

Adding a site-wide password is not a security breach. Please read the documentation at the link provided to understand how it works.

We can then take a look at your issue.

A common issue when this happens is Custom CSS is interfering with the layout. If you've used custom CSS remove it, make a copy somewhere, and see it the issue goes away.

Find my contributions useful? Please like, upvote, mark my answer as best , and see my profile. Thanks for your support!

Link to comment

Okay. I have tried to set a password, I click "save" and nothing happens. Almost as though the screen is frozen, similar to my issue above. Again, I tried this in different browsers to see if my browser is slow or whatever. Also, I noticed today that my Main navigation is empty and all the pages I built are Not Linked

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...