Jump to content

Unable to add images (or other content blocks) to blog post

Recommended Posts

Site URL: https://www.andrewroosbell.com/blog

I just switched to Squarespace from Wordpress, and I imported all of my blogs, including their images. After I had imported them, the blogs appeared on Squarespace with the images as originally formatted. A couple of days later, after I had transferred the domain to Squarespace, the images in the blogs (not any other images on the site) had disappeared completely. 

Then, I tried to post a new blog containing an image, but I found there was no option to add an image content block (or any content block). I thought perhaps the problem was my template, so I tried to find a way to try a different one, but I couldn't find that either. 

Any help is appreciated. At this point I'm really baffled and kind of at a loss - I was hoping to get things up an running pretty quickly, and I made the switch largely because I had struggled a lot with issues at my previous host (I am not very tech-oriented). 

EDIT: I feel a bit silly, but I did just find the option to add an image block - I was really thrown by it being completely invisible, but it is there. The issue of the vanishing imported images is still outstanding, however. 

Edited by Chrysalteor
Correction with new information
Link to comment
  • Replies 0
  • Views 268
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.