Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0
ap2006

Can't seem to embed Convertkit form in 7.1

Question

Posted (edited)

Site URL: https://www.thewritinghive.co/

Hello - I'm having trouble embedding an inline Convertkit form onto my Squarespace 7.1 site. I have a Business plan and I copied and pasted the Javascript code into a code block. But all it's showing is the actual line of code and not the form. I've tried this on a number of pages and nothing seems to work. 

I checked the src url and it's broken too but I don't know how to fix that. Does anyone know if that's where the issue is coming from? Convertkit support is quite slow and I don't know who else to ask.

I'd appreciate any suggestions as I don't want to use the Zapier integration.

Screenshot attached of what I see - and you can see the code at www.thewritinghive.co on the home page if you scroll past the first block of text, it's embedded there. 

Thanks in advance anyone for your advice!

 

 

Screen Shot 2020-07-09 at 3.01.10 PM.png

Edited by ap2006
missed a line

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

Thank you for asking this.  My exact question as well.  

I've seen tutorials that show there is no need to use zapier and just embed the javascript but the response emails from support I received say you need zapier.  

I am going to try this and if I have success I will report back.  

Share this post


Link to post
  • 0

Was able to get the convertkit form on but I need to disable zapier now and see if it all works. 

 

You are definitely posting in javascript? My form said "Hello World" I copied my convertkit javascript over that and it said "script disabled" I saved my work and then the form popped up.

Share this post


Link to post
  • 0

Just an update: As the email from squarespace support said, my only success was with Zapier in the 7.1 version.  

Share this post


Link to post
  • 0

Hi Katee!

Thanks so much for your replies! 

After a couple of days, my own troubleshooting, and a bit of help from Convertkit, I managed to embed the HTML version on my 7.1 site without having to use Zapier. I'll detail all the steps below:

The first thing I did was in Convertkit, I went to the 'Embed' button and I copied the 'HTML' code. I didn't end up using the Javascript code. 

Then, I went to my Squarespace 7.1 site and added a 'code block'. By default it's on HTML. I left the 'Hello World' stuff there just as a placeholder, and pasted in the embed code. It's pretty long. Then I hit 'Apply'. That made the form appear, but the words 'Script Disabled' were still above it. 

What I did next was I used Ctrl F to find all the instances of 'https' in my form code. You have to remove the 's'. I'm not sure why that fixes it, but it does. So I found 3 cases of it in the form I used and changed all of the 'https' to 'http' in the code block. Then I hit 'Apply' > 'Save' on the site, and reloaded it. And it works fine now. 

I also tested it and it ended up sending my emails perfectly. I have only tested it with one address so time will tell if it continues to work but I'll post here again if I have issues. 

The only reason I can think of the javascript code not working is because there's something weird about Ajax in 7.1 sites. I'm reluctant to use 7.0 because I feel over time Squarespace will create more and more things in 7.1. 

You can definitely still use Zapier but I'm ok using the HTML code. With Zapier you only get 5 zaps to start I think and there is a 15 min delay with each sign up on the lowest plan. It can get very expensive when you are just starting out as a business owner (like me!) so I am trying to keep things low!

Let me know if you have any questions, always happy to help if I can!

 

 

Share this post


Link to post
  • 0

Hi Ap2006- I tried your approach, and it looked like it was working for a minute, then the page seemed to reload and it had all disappeared except the Hello World! I am completely flummoxed! Thoughts? How did you figure out about the http code needing to change? Wondering if there are other resources I can check out. I haven't had luck with Convertkit getting back to me. 

Screenshot 2020-07-20 at 1.55.32 PM.png

Share this post


Link to post
  • 0

Hey @Arianababy I'm so sorry I didn't see this till now!

So for the 'Hello world' text you can actually just go ahead and delete it. You don't need it.

All I did was remove the 's' from any 'https' in the code from Convertkit once I'd pasted it into the code block in Squarespace. You do have to refresh and save everything. Sometimes it takes a minute or two to work. But I am able to successfully see my forms on different pages on different sites. I even tried it with the free Convertkit account and it worked. 

One thing to note is don't worry if you can still see 'Script Disabled' when you're in edit mode. It goes away when your site is live. 

I'm not sure if you managed to resolve this but if you are still having trouble, let me know!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...