Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0
JamesGraham303

Title over background video - custom code fix

Question

Site URL: https://www.richtr.io/

Hi, 

I had a title hovering over the video in a banner box on my homepage and somehow it disappeared, not sure how. 

It was originally placed there by an agency that custom coded a lot of the site. Now the title is gone and has been replaced with the Company name and will only render as transparent. The banner box is still visible when trying to edit although I cant see anything in the box. I checked the code and its set to display as white text. there must be another issue with the code but I cant figure it out.

Can anyone help?

 

Share this post


Link to post

1 answer to this question

Recommended Posts

  • 1

Hey @JamesGraham303,

Looks like there's a missing </script> tag in your custom code.

From the main Squarespace editor, navigate to Settings > Advanced > Code Injection. Scroll down to the Footer Injection, and find a bit of code that looks like this:

window.onload = showHeroText();


<!-- Start of HubSpot Embed Code -->

You'll want to edit it to look like this:

window.onload = showHeroText();
</script>

<!-- Start of HubSpot Embed Code -->

This closes out the script that makes the banner text work before moving on to start the HubSpot script.

Hope this helps!
-Tyler


Is your Squarespace website ADA compliant? Find out in 60 seconds with our free accessibility audit!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...