Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search


Circle Member
  • Posts

  • Joined

  • Last visited

Posts posted by Millermore

  1. On 4/17/2021 at 12:44 PM, switch1 said:

    ok i found the place where you insert the code, but it's still not working for the mobile view of my lightbox. when i click into the lightbox button, the form pops up, then as soon as i click the first text box, the keyboard still covers half of the lightbox so i cannot finish the form. any suggestions?

    The solution I posted is for the standard forms, not the lightbox versions. Not sure how to solve it for the lightbox forms. You can try the standard form with the solution I posted and see if that's better than what you have now.

  2. On 4/18/2021 at 8:03 PM, amritanan said:

    Any idea how I can avoid the input field zoom-in on iphones? This is the page - https://www.lighterbrighteryou.life/contact My client says she is unable to see the bottom two fields and the Submit button in any form, but it is working perfectly fine on my phone and I cannot figure out the problem @tuanphan Thank you!

    It looks fine on my iPhone. Try adding the code I posted above. Maybe they have zoom/larger text for accessibility on their phone which is making everything look larger for them? Maybe that's causing an issue. Otherwise, looks find, I can see the submit button, but it still zooms in, so try the code above.

  3. Actually just found a solution on this page: https://www.warrenchandler.com/2019/04/02/stop-iphones-from-zooming-in-on-form-fields/

    I went with the meta tag solution. I placed the meta tag on the page settings with the contact form I wanted to fix, in the Advanced area -> Header code injection.

    Just enter in:

    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0,user-scalable=0"/>
  4. I just had a lead tell me they had this "issue" with the form zoom in on their phone. I'd also be interested in a way to prevent this. I tried this on my iPhone on a Wordpress site I built with Gravity Forms, and there is no zoom in. I understand it may be a feature of iPhone or iOS, but there's either something with Squarespace forms that trigger this zoom in effect, or others like Gravity Forms that prevents it.

  5. My thoughts are that Squarespace needs to take this seriously, or else people may jump ship to another web builder. Since we have absolutely no control over these things to optimize performance, this may push people to start looking elsewhere. Hopefully they are planning on addressing this in a new version of Squarespace, such as 7.2 or 8. It's frustrating because for all of the great features within Squarespace, the beautiful templates and user-friendliness of the platform, there are several areas Squarespace ignores or drops the ball. In the years I've been using the platform, as an example, I don't remember any updates to the Form block functionality, even after other platforms such as TypeForm revolutionized web forms. But Core Web Vitals is the type of "con" to weigh so heavily, with no solution for optimizing performance, it may push even the most ardent supporters of Squarespace to look at other platforms. The first competitor to address this could see a lot of new subscribers, so hopefully it's something Squarespace doesn't just ignore, as there is a huge opportunity for them to steal people away from their competitors, rather than lose them.

  • Create New...