Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

How can I turn off auto scaling for images?


Bumper
Go to solution Solved by krystynheide,

Recommended Posts

Hello all,

Can anyone tell me what CSS code would turn off auto scaling for images within gallery blocks?

According to support the template I am using does not support such a feature and would require CSS. I am willing and (relatively) able to experiment with CSS but am in the dark as to where to start.

My project width is scaled to 1500 which is great for my renders (I'm a computer games artist) but not so great to display my texture maps (some of which are 512 wide) as they stretch up to 1500.

I have forum/google searched to no avail. Any help would be appreciated.

Thanks!-Lee

edit 4/4/13- I have abandoned stacked and am now using slideshow. Images still auto-scale however. There does not seem to be a stable way to turn it off. Very disappointing that something so simple is out of our control. Boo (otherwise awesome) Squarespace!!

Edited by Bumper
Link to post
  • Replies 20
  • Created
  • Last Reply

Top Posters In This Topic

This will keep them the original size:


.image-stack .image-wrapper img {
 width: auto;
}

You can also add a min-width to keep them from displaying too large:


.image-stack .image-wrapper img {
 width: auto;
 max-width: 100%;
}

Edited by krystynheide

I'm Krystyn Heide, a designer and developer living in New York City.

Link to post
  • 1 month later...
  • 3 months later...

I have the same issue, all images are 720px wide in my galleries, and yesterday, no problem, I came back today however and they have all been scaled up and are now blurry. I added the css above, which worked a few days ago before rescaling the images, and still no luck??

Edited by Nathan Jackson
Link to post

So it worked great (thx squaregirl) as far as getting the images to not scale beyond their resolution (width), but is anyone else getting a ton of blank space between the image and the content beneath it now? How do you solve this?

Link to post

I can't seem to find this option, there is "Product Gallery Auto-Crop" however unchecking this did nothing, as I assume, it relates only to products on a shop page. I think the problem people are having relates to gallery pages on the main page?

Link to post
  • 2 months later...

Something changed since the solution was posted, this is what works (somewhat) for me.


.sqs-gallery-design-stacked img { attributes }

I say somewhat because a large amount of white space is added beneath the gallery if you re-size the height, and I'm unsure how to fix that.

Edited by redpox
Link to post
  • 2 weeks later...

I feel like I'm stuck between a rock and a hard place:

I need the titles of my gallery pictures to be visible, so I can't use the grid gallery.I can't have my gallery pictures auto scale, so I can't use the slideshow.

I'm still using my trial of Squarespace, and there's so much that I like, but without an adequate answer to this, I won't be giving them my business.

Link to post
  • 2 months later...
  • 3 years later...

2 questions:

Is there a solution for keeping lone images from scaling (not gallery blocks)?

Where are you injecting this string of code if you don't want this to be sitewide?

Thanks!

Link to post
  • 4 months later...
  • 1 year later...

Hi @Bumper, I made a video tutorial for you on how to Turn off Auto Scaling For Images. Hope this helps! https://www.askquesty.com/post/turn-off-auto-scaling-squarespace

Edited by AskQuesty

Have Squarespace questions/task and need help today? **You can hire us here.** Our answers are on-demand, video recorded, and only cost between $5 to $25. Estimates are free, 100% satisfaction guarantee, and trusted by hundreds of small businesses.

Link to post
  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...