Jump to content

Cant upload any images, delaying website publishing

Recommended Posts

Hello,

 

I've been trying for a while now, read all the posts related to uploading images and i still cant manage to upload any image. not on my main page/products or even my logo throughout the site. its disappointing as i've been hoping to launch my website but its getting delayed. I would appreciate any support, i would like to get this resolved asap.

 

thank you in advance.

Link to comment

Have you tried contacting Squarespace Support?

https://support.squarespace.com/hc/en-us/requests/new#choose-topic

This doesn't sound like something that can be solved by the community, but you could try clearing your browser cache as that might be causing the problem.

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment
10 minutes ago, nowal said:

I've minimized the images and are saved as .PNG format. I tried .JPEG as well. 

Could you share one of the images so I can test uploading it myself?

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.