Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 6

Summary Block: How can I set the Carousel to "autoplay"?


jasonbarone

Question

I love the new Summary Block carousel. I'm curious if it's possible to "autoplay" the carousel much like galleries can do. I know this is possible using Developer Platform galleries, but would love to be able to use with Block Carousels.

Edited by rhyann

Founder at Squarefront, the global community of Squarespace builders. I'm building products and services for the Squarespace platform and documenting everything on YouTube. I've been working with the platform since 2008 and my work with Squarespace led to me being hired by Uber where I spent over 5 years working on the web, design and content platform teams. 

Need help with Squarespace? Send me an email! Otherwise connect with me on TwitterInstagram, or Linkedin.

Link to comment

Recommended Posts

  • 0

Hey, I've got this working now! But... HELP... I can't figure out how to adjust the speed of the carousel. It's just whipping around every 2 seconds or so and I've tried changing the var duration to 50,000 and nothing changes!

I do like the hover feature that stops the ride!

Link to comment
  • 0

ghostcat this is awesome, works great!

As a nit-picky bonus is there any way to make it advance one image at a time? I have it set to show three images at once and when it advances it scrolls all the way to the next three instead of just shifting over one. Not a huge deal but would be an awesome addition if possible!

Link to comment
  • 0

Mine no longer autoplays on desktop versions, only on mobile... Still can't figure out how to make the same apply to all carousels :(

EDIT: Oh yeah- I see what you mean about the white box at the end, it's doing the same on mine... sigh

Edited by Roppo
Link to comment
  • 0

IMPORTANT!!!The code works with the carousel but it effects the rest of the page to much.There is a bug in the code, but I can't find it. In Avenue when inserting the code the thumbnails of the index grid disappear and in Marque the image gallery page disappears.

Link to comment
  • 0

IMPORTANT!!!The code works with the carousel but it effects the rest of the page to much.There is a bug in the code, but I can't find it. In Avenue when inserting the code the thumbnails of the index grid disappear and in Marque the image gallery page disappears.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...