Jump to content

Custom DNS Record Cannot be Saved

Go to solution Solved by TMPPro,

Recommended Posts

I submitted a support request last week, and the agent said to delete the Squarespace Default DNS Records and then add the Custom DNS Entries. Of course, I had already tried this, and received the error message. However, after being away from the Squarespace admin console for a day or so, I tried it again. It magically worked for one custom CNAME entry. There is some sort of bug in their admin console.  Unfortunately, when I tried to add the 2nd custom CNAME entry, it goes back to giving me the same error message. 

Link to comment
  • 1 month later...

I cannot add custom records to my domain. Yes, I have removed the squarespace default already. Still getting the response below when adding records.

Custom record not saved

We were unable to save this record. Try again later. If this problem continues, contact Customer Support.

Link to comment
  • 4 weeks later...

This has been coming up a lot lately! It sounds like it might be a browser cache issue of some sort.

Logging out and then logging back in does seem to help for most people. You can use an incognito / private browser window, which logs you out of your account automatically. 

Link to comment
  • 2 weeks later...

Clicking Delete or Add results in the error: "We were unable to save this record. Try again later."

 

I'm unable to modify any DNS settings at all leaving me blocked on work I need to do. I never had this problem with Google. Not only that but all of your pages will occasionally randomly refresh. I am in awe at how terrible this product is - it doesn't even work. 

 

Link to comment

I am attempting to add my Squarespace site manually to the Bing Webmaster tool.

I have a personal Squarespace account and cannot utilise the HTML Meta Tag option, so I am using the Add CNAME option.

I go to Squarespace Domains / DNS / DNS Settings and open "Add Record" at the 'Customs Record' section at the bottom.

There are two Squarespace defaults showing - a type 'A' and a type 'CNAME'.

I select type:  CNAME,
I add the alias data:  verify.bing.com
I input the name as given by Bing (mix of 32 letters & numbers)
I hit save and a message quickly flashes up on screen for less than a second stating the record can't be saved.

I have done this a number of times with the same result each time, with Bing confirming it cannot verify the site.  This appears to be is a Squarespace problem, not a Bing problem.

If anyone is able to provide some advice on what I may be missing here, it would be appreciated.

Thanks in advance,

Walter

 

Link to comment

Had these same issues. The key to modifying your DNS records is to log into your SquareSpace account using an incognito window. (I use Chrome). It's the only time the system will accept edits, deletions, or additions from me. 

Link to comment
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.