Jump to content

Home Page takes forever to load

Go to solution Solved by GeriYoung,

Recommended Posts

Hello,

My business website takes forever to load. I've optimized pictures to lighten every page but it's still giving me the same issues. I encounter the same problem on Mobile & Desktop. I've tried to check the weight of each page and it seems to be light enough. After running a diagnosis from PageSpeed Insights, here are the results: https://pagespeed.web.dev/analysis/https-www-mllegeri-com/lbnwy8m01o?form_factor=mobile

What can be done about this? I hope I've provided enough details.

Thank you

 

 

 

 

Link to comment
  • Replies 2
  • Views 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

49 minutes ago, GeriYoung said:

My business website takes forever to load.

The site loads quickly but some content is unavailable:

  • the video xkEmYQvJ_68 doesn't load because it is private (401 Unauthorised)
  • the image 1fevrier2022_Joby__00198+copy.jpeg doesn't load (404 Unavailable)
  • the image Geriportrait.jpg doesn't load (404 Unavailable)

Did this help? Please give feedback by clicking an icon below  ⬇️

 

About me: I'm Paul. A SQSP User for 18 yrs, I joined Circle when it launched in 2016 and have been a Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL, providing expertise and extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is free. You can thank me by clicking one of the feedback emojis below. Coffee fuels my work.

Book paid help with a Squarespace Domain

Link to comment
  • Solution
3 hours ago, paul2009 said:

The site loads quickly but some content is unavailable:

  • the video xkEmYQvJ_68 doesn't load because it is private (401 Unauthorised)
  • the image 1fevrier2022_Joby__00198+copy.jpeg doesn't load (404 Unavailable)
  • the image Geriportrait.jpg doesn't load (404 Unavailable)

Did this help? Please give feedback by clicking an icon below  ⬇️

 

Hello Paul,

Thanks for you reply. The website still loads slow. My page speed index is at 9.1 as per the report I just sent you. I experience it whenever I load my website from my phone and or desktop so it's definitely not fast. 

I have removed and added the last JPG but I can't seem to find the other files... Do you have a thread or can you offer some precise help as to how I can one diagnose this on my own in the future and how I can fix this speed issue on my home page?

Thank you

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.