Jump to content

Background video will not auto-play on Safari on iPhone, but auto-plays on Chrome and Firefox on my cell phone and windows computers

Recommended Posts

Hi. Here is my site: loreal-speed.squarespace.com. I'm trying to add a background video in such a way that it auto-plays on the Safari web browser. The background video works as expected on my Windows laptop/desktop computers, and Samsung S23 Ultra in the Chrome browser, by it doesn't play on my girlfriend's iPhone 12. This video in question is an .mp4 video file. I did have my stepson, who has an iPhone 15 Pro, view the same site, and he can see the background video playing. 

Any suggestions? 

Edited by wolfpassion20
Link to comment
  • Replies 4
  • Views 1.8k
  • Created
  • Last Reply

Top Posters In This Topic

On 10/20/2023 at 2:26 AM, npettersson said:

I am having the same problem. @tuanphan were you able to fix the issue? Can you help me?

I usually use video with Code Block, something like this

<video autoplay>
  <source src="https://www.w3schools.com/tags/movie.mp4" type="video/mp4">
</video>

 

Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

Contact Customer Care - Learn CSS - Buy me a coffee (thank you!)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.