Jump to content

I have an anchor link that works randomly

Go to solution Solved by Turbiville,

Recommended Posts

The password is - demo

https://blue-oarfish-27kp.squarespace.com

The link to "demos" only works sometimes.  Also I've used the anchor link function and if I'm in another page like "contact" and click the "demos" link, most of the time it just returns me to the homepage or doesn't do anything at all.  If I'm on the home page sometimes clicking "demos" will scroll me down to the "demos" section, and sometimes clicking it does nothing.  I see some people using different code for anchor links as well, so it's a bit confusing.    Can anyone help?  

I know the button for the FTVA member area is empty to for now if you click it, it's just a temp member area until I build that out, but for now all the other menu nav button need to work as they should. All of them do, but the "demos" anchor link.  I didn't want to do a full separate page for them, I just wanted to have a visitor click it and have the site scroll down to that section, or if they were on a separate page like "contact" have it take them straight to the demos section on the home page. 

Thank you for the help in advance. 

 

Link to comment
  • Replies 2
  • Views 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

also side note.  I did use the /home#demos in the Anchor Link under Main Navigation so clicking it from another page will direct to the home page then the demos section, but that wouldn't work either.  SO using just #demos or /home#demos gets me the same result of randomly working. 

 

Edited by Turbiville
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.