Jump to content

Unable to push blog posts to Facebook even though Facebook is listed as a connected account

Go to solution Solved by ceoparker,

Recommended Posts

1. Facebook is listed as a connected account (push enabled), but the Push Target dropdown list is not visible under Facebook setting so I can not select a site (I only have 1 site)

2. Under Blog Post Settings -> Share, Facebook is not listed as an account


I've reached out to support multiple times, no one seems to have an answer. I have disconnected and reconnected my Facebook account several times, refreshed my Chrome browser, cleared my history, nothing helps.

Hoping that someone here can offer some suggestions to resolve this issue?

Much thanks,


Blog Post Settings.png

FB settings.png

Link to comment
  • Solution

After much communication with Squarespace Support (they were very patient and helpful via email), the ultimate fix was:


  1. In Facebook > Settings and Privacy > Settings > Business integrations, beside Squarespace, click Remove.
  2. Log into Squarespace and navigate to the Settings > Connected accounts panel.
  3. Click the Facebook account, then click Disconnect and Confirm.
  4. Re-connect the Facebook account https://support.squarespace.com/hc/en-us/articles/206544007-Connecting-Facebook-to-Squarespace
  5. Click Okay for each of the permissions questions you're asked, if you are comfortable with the permissions that are needed to connect your Facebook page to your Squarespace site.
  6. When you're done, click the newly re-connected Facebook account again and see if your page appears in the drop-down.

Even though I had tried this many times, this last time seemed to fix the issue.

Good luck, hope this helps you as well!

Link to comment
  • 5 months later...

I have been trying to figure this out for hours. I am trying to connect to a business page and it is not working. This needs to be resolved ASAP. I lost the connection in November and missed out on pushing like 30 articles through my business's page on Facebook.

Link to comment
  • 4 weeks later...
  • 1 month later...

When I used the instructions from ceoparker, I did not disconnect the Squarespace integration in the Facebook Settings. Instead, I clicked "View and edit" and clicked the checkbox next to the page that I wanted to allow posts to publish.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.