Jump to content

Custom Fonts Not Showing

Go to solution Solved by tuanphan,

Recommended Posts


I've added a custom font to my website, and added the "!important;" next to it, and it is still not showing. Below is the code. 
It is only appearing on Google chrome on the mac where the font is installed on the mac. Safari doesn't load it. Additionally, on other PCs and mobile it does not load. Can someone please support in this? It is for an important event going live soon.

@font-face {
font-family: 'SOLAR-VESTA-SERIF' !important;

h1 {
font-family: 'SOLAR VESTA SERIF' !important;

Link to comment
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

  • Solution

First, remove !important in first arrow. This will make font-face code invalid

Second, make sure both font name are same


Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

How to: Setup Password & Share url Insert Custom CSS - Page Header - Upload Custom Font - Upload File - Find Block ID - Contact Customer Care

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.