Jump to content

Forms not saving changes

Recommended Posts

I’m currently trying to link our mailing list service as “additional storage” for a newsletter sign up form, and despite connecting it about 4 or 5 times now, the “save” option doesn’t appear until I edit a text block (I literally just add a space and then delete it to make the “save” appear), and when I save and then exit, the form doesn’t stay saved. 

I get NO error messages from any end. Apparently, the mailing list seems to connect just fine every single time. None of the form field edits are saving (I tried changing the button text from “Submit” to “Sign Up!”), and each time I check after saving and exiting, the mailing list isn’t connected to the form.

I’ve tried to change the fields on another one of the forms on my organization’s page, but gave up after new fields wouldn’t stay saved. I would like to figure out what the problem with that form is, but it’s not as big of an issue as the newsletter form at the moment.

Link to comment

I forgot to add for context: I primarily work on ipadOS, so I tested connecting the form to our mailing list service on a Windows PC and the same thing happened. No error messages, just the same “save” option not appearing until I edit a text block, and then the form’s changes not saving.

Link to comment
  • 4 months later...

is there a resolution for this anywhere? I am pulling my hair out trying to put a site live (I've upgraded my subscription to see if it help).. I select different text colours and try to add links but it just does save / update. Its a fundamental function that just isn't work 🤦🏼‍♂️

Link to comment

I had a chat with Squarespace support about this issue this morning - here is the key to their response;

 I do see we have a recent known issue on form and newsletter blocks not saving in additional info sections for products. 
I've just now noted your report and case with our Engineering and Design teams for review so they can take a closer look at your website.Thanks again for reporting this, the engineering team will now have a closer look for you, 

Unfortunately, the last time they said that their Engineering Dept was going to look into a support issue (a different problem) was over a year ago - and I have yet to hear from them.  Perhaps if everyone experiencing this problem were to contact customer support, they would devote more energy to it.  

As I have been connecting various Mailchimp lists to Squarespace forms for many years - it seems to be that some behind the scenes "upgrade" has broken this.

Link to comment

I noticed this today and found a workaround.  If the "save" button is grayed out, go into a text section, and make a change (you can immediately undo it). The save button was reactivated for me. (I use the Firefox browser, so not sure if it has anything to do with the browser.) 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.