Jump to content

Widget Code Not Formatting Correctly

Go to solution Solved by dirtywater24,

Recommended Posts

I am having some trouble with a widget I am trying to add to my site.  In the preview on the backend, the widget is loading the schedule properly but when I navigate to the published page, it doesn't load.  I have attached a screenshot of what it should look like when it loads and what it DOES look like on the backend.

 

Screen Shot 2023-08-22 at 10.37.12 AM.png

Link to comment

I only see the one screenshot. Can you share your website URL and this page?

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Another thing I have noticed is that in the preview mode, the page doesn't refresh, it merely loads the appointment times.  On the published page, the page actually reloads and takes you to the top.  I'm guessing this is part of the problem.

Edited by dirtywater24
wrong word
Link to comment

To me this looks like a problem with the code, have you checked with Mind Body Online as to why this might be happening?

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Yes, of course they said there's no problem on their end since the code shows up properly on their site as well as the squarespace preview.  I do think it's a squarespace issue since the code works fine on the backend.  I am convinced it has something to do with that screen refresh thing but I can't figure out why it refreshes in the published view but not on the back end.  

Any thoughts on why that might be the case?  I have attached a screen recording showing what happens on the published page when I try to load the appointments.  You can see the page completely refresh.

Link to comment

Can you share the code, I'm not sure what's causing the refresh, but it's likely not helping. I don't see that myself, but it still doesn't load the search.

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.