Jump to content

Trouble with Javascript embed form code

Go to solution Solved by Kelsey-atl,

Recommended Posts

Hi All,

I am having issues with an embed code that appears to be javascript. "Join The Waitlist" form is a Hubspot form embed. Unfortunately, a few boxes and the submit button will not load consistently across devices or other browsers unless refreshed. A notorious one I can replicate the issue on is Safari. When I clear my cache and history, I can recreate the issue every time. 

https://www.wearethelo.com/#membership

I would be forever grateful for any insights or help with this issue.

I've read a few places about disabling Ajax loading but could not figure out how to do this with Squarespace 7.1. 

Screenshot 2023-07-24 at 6.09.08 PM.png

Link to comment
22 hours ago, Kelsey-Atlanta said:

"Join The Waitlist" form is a Hubspot form embed. Unfortunately, a few boxes and the submit button will not load consistently across devices or other browsers unless refreshed.

I see this on Safari too. At least until the form is clicked, at which point the rest of the form loads.

I don't have a definitive answer but it looks like this could be an issue with the way the HubSpot embed code works. Because the form is at the end of your page, it is not visible when the page loads and so the form may not be able to determine the correct height for the iframe. It would then only show the first part. For troubleshooting, it may help to move the embed to the top of the page to see if the issue persists here. If this is the issue (and it's a stab in the dark) you could try setting a height to the iframe manually.

Me: I'm Paul, a SQSP user for >18 yrs & Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL. We provide high quality original extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is completely free. You can thank me by selecting a feedback emoji. Buying a coffee is generous but optional.

Link to comment
  • 1 month later...
  • Solution

Thank you for responding, @paul2009. I did want to leave a (solved) update here in case someone else runs into the same issue in the future.

Hubspot has a new beta form called the V3 form. This updates the embed code to prevent issues such as the one I was having. Until they are fully released as a permanent solution, I was able to sign up through Hubspot support team to be in the beta user group. Once they activate V3 beta forms in your Hubspot account, you will need to rebuild the form to have a new embed code. If you try to duplicate the form, it will still use V2. 

It looks like Hubspot is making these form updates because of issues like these, so I am happy to see they're already working on it!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.