Jump to content

How to disable Hover Button

Go to solution Solved by creedon,

Recommended Posts

If you want a link without a background or border, can you not just use text link rather than a button?

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Is this the effect for buttons you want to get rid of?

If that effect is removed, how does the user know they are hovering over a link?

Edited by creedon

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment

Yes, that is the effect I would like to remove. I am planning on changing the button to text links where the arrow will be at the end of the word to indicate that the text is linked to another page. I was just curious about how to disable the effect anyways.

Link to comment
  • Solution
Quote

Yes, that is the effect I would like to remove.

Add the following to Design > Custom CSS.

@media ( hover : hover ) {

  .primary-button-style-outline .sqs-button-element--primary:hover {
  
    background : unset;
    color : unset;
    
    }
    
  }

Let us know how it goes.

Edited by creedon

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment

I fixed it by changing the color of the background. In your case, add black color primary button background and white to primary button text

 

See steps below...

 

1. Edit

2. Click on button (storyboard)

3. Top right (site styles)

4. Colors

5. Click on (Aa lightest 1)

6. Click on button (storyboard)

- options to change colors for that button will pop up

 

Let me know IF this helps

Link to comment

Thanks for the suggestion! However this doesn't solve the problem. Following the steps you listed, the hover effect was not disabled, adding black to the button background just helped to hide it. When I hovered over the edited button there was still a hover effect in place. I have managed to fix this problem from another solution posted, thank you for your help!

Link to comment
  • 1 month later...
8 hours ago, Emoke said:

I tried simply copy pasting it but it didn't really make a change. Should I change something in the code?

Please post the URL for a page on your site where we can see your issue.

A link to the backend of the your site won’t work for us, i.e. a url that contains /config/.

Please set up a site-wide password, if your site is not public and you've not already done so.

Post the password here.

Adding a site-wide password does not allow anyone to alter your site. It only allows those with the password to see your site.

Please read the site-wide password and how to share a link documentation to understand how they work.

We can then take a look at your issue.

You may find How to post a forum question post useful.

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.