Jump to content

Help With Anchor Links

Recommended Posts

Hey y’all!

 

I have a question about my site regarding the functionality of my anchor links, especially when viewed on a phone.

 

My site is a one-page scroll with a solid amount of content on it. I believe the anchors are correctly coded for the most part, but unfortunately the anchor links aren’t functioning perfectly.

 

When I open my site and click the last link in my menu, “Contact,” for instance, it doesn’t scroll to “Contact.” It will scroll to the middle of the section above it, or maybe somewhere else. My instinct is that it’s because my site isn’t loading fast enough. The anchor link is trying to scroll to a place on the site that hasn’t yet loaded, and it can’t.

 

Is there any fix to this? I’m not sure if maybe there’s a way to make a site load all of the site at once, or not display the site until it’s entirely loaded? How can I improve the functionality!?

 

Any help would be so amazing, thanks! It’s messed up on my desktop and the computer.

 

Full Disclosure: My site has some NSFW material. It’s mild nudity, all artistic, nothing too crazy!

 

Spencer-clark.com

Edited by spenni
Adding website
Link to comment
  • Replies 3
  • Views 310
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

1 hour ago, spenni said:

Hey y’all!

 

I have a question about my site regarding the functionality of my anchor links, especially when viewed on a phone.

 

My site is a one-page scroll with a solid amount of content on it. I believe the anchors are correctly coded for the most part, but unfortunately the anchor links aren’t functioning perfectly.

 

When I open my site and click the last link in my menu, “Contact,” for instance, it doesn’t scroll to “Contact.” It will scroll to the middle of the section above it, or maybe somewhere else. My instinct is that it’s because my site isn’t loading fast enough. The anchor link is trying to scroll to a place on the site that hasn’t yet loaded, and it can’t.

 

Is there any fix to this? I’m not sure if maybe there’s a way to make a site load all of the site at once, or not display the site until it’s entirely loaded? How can I improve the functionality!?

 

Any help would be so amazing, thanks! It’s messed up on my desktop and the computer.

 

Full Disclosure: My site has some NSFW material. It’s mild nudity, all artistic, nothing too crazy!

What's the URL so we can check?

Sayre

Design: (Recently rolled into the Italian Journey under Services)

Author Coordinates: https://bio.site/sayreambrosio

Italian Journey: https://bio.site/ambrosiosjrnyhm

Link to comment
21 hours ago, sayreambrosio said:

@spenni NEVERMIND lol I found it in a different post. It's working correctly for me. I tested on desktop Safari and Chrome and mobile in Safari.

omg! I thought I edited the post! my bad!

 

It's Spencer-clark.com

 

Okay! HMM I wonder why it doesn't work for me. thanks!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.