Jump to content

Recommended Posts

I have a third party domain on my site which is connected correctly and seems to be working fine at first. However Ive found that when I use certain links within my site, the page that loads next will use the built-in domain that Squarespace assigned me. It then uses this domain in all the page url's after this, until I type my primary one back into the browser. I had thought that the built-in domain was just used for editing in the back end.

Has anybody experienced this before or know what I may be doing wrong?

Link to comment
  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

18 minutes ago, max2468 said:

Has anybody experienced this before or know what I may be doing wrong?

This usually happens when you put the full (built-in) domain into a link rather than just the URL slug, so when you're on your custom domain it then forces a switch back to the SQS built-in domain.

Best practice for internal links is just to use /url-slug rather than https://domain.squarespace.com/url-slug.

Hope that you can find these rogue links! Good luck!

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.