Jump to content

Font Pack Headings Displaying Incorrectly

Go to solution Solved by eyespriedopen,

Recommended Posts

I’ve completely redesigned my site (https://eyespriedopen.com) from scratch in Squarespace 7.1 after having originally built it in EverWeb.

I transferred my domain from Web Hosting Hub to Squarespace and the site successfully transferred last night.

I’m using the Acumin Pro font pack with Acumin Pro for headings and Poppins for paragraphs. When my site transferred last night, the headings are now rendering as a serif font (Times Roman or something).

As you can see from the screenshots with the word "EUROPE," my editing panel uses the correct font and the Squarespace URL (https://eyespriedopen.squarespace.com) also renders the font correctly, just not the public site.

Any ideas how to fix the problem? I’ve cleared all my browsers and it still is showing incorrectly on my MAC, iPhone and iPad.

Thank you.

Screenshot 2023-05-16 at 9.07.23 AM.png

Screenshot 2023-05-16 at 8.32.39 AM.png

Link to comment
  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I can certainly confirm that it's not working on more than just your MAC, iPhone and iPad (Chrome on Windows), but I can't see a specific reason why this would be. It's correctly in the style sheet, but it doesn't apply. Have you done anything in Custom CSS or Code Injections?

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Thanks, Ziggy. I have one Custom CSS to remove the underline from my footer links, but that is it:

footer .sqs-block-html a {
  background-image: none !important;
  background-repeat: no-repeat !important;
  text-decoration: none !important;

#page .content-wrapper {
    padding-top: 0;
    padding-bottom: 0;


This issue just presented itself once my domain was successfully transferred to Squarespace from Web Hosting Hub. I'm not sure if that might be the problem, although the Squarespace site editor and the internal link in for my domain in Squarespace appear correctly. I also noticed the wrong font is displaying on my main portfolio pages, too, where the section captions are.

Link to comment
  • Solution

Squarespace customer support replied with the following, which worked for me:

"We are aware of a system wide issue in which fonts are not rendering properly when viewing the site using its custom domain. To resolve this issue, you can set your custom domain as the primary domain..."

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.