Jump to content

Problems with SS + iCloud Settings for Email Using Custom Domain

Go to solution Solved by paul2009,

Recommended Posts

I have a client with a Squarespace-hosted domain who wants to use custom email with iCloud+. I've entered the supplied DNS records, following the instructions from Apple to first try the records as provided and, if those don't work, to make some adjustments. 

These included removing the period at the end of MX records and the quotes from the SPF record. Both adjustments were required. (See attached screen grab of Apple's instructions.)

The DKIM record, which also has a terminal period, was accepted by the SS DNS as provided, so I did not remove it.

After 72 hours, the email doesn't work.

After an hour on a support call with AppleCare, the email doesn't work.

After removing the incomplete email setup on iCloud and going through the process of adding the custom email again, it still doesn't work.

After publishing the site, which was set to private ahead of launching in a few days, it still doesn't work.

Discrepancy: While troubleshooting, I found that in Apple's instructions, the DKIM settings specify the Type as a CNAME record. But, in Squarespace help pages for SPF and DKIM records, SS says it should be entered as a TXT record. I have done both, and neither work.

AppleCare was stumped and suggested contacting Squarespace.

So, what now? Anyone?

Screen Shot 2023-05-15 at 2.46.02 PM.png

Screen Shot 2023-05-15 at 3.04.20 PM.png

Screen Shot 2023-05-15 at 2.45.22 PM.png

Link to comment
  • 4 weeks later...
  • Solution
On 5/15/2023 at 10:11 PM, texalot said:

While troubleshooting, I found that in Apple's instructions, the DKIM settings specify the Type as a CNAME record. But, in Squarespace help pages for SPF and DKIM records, SS says it should be entered as a TXT record. I have done both, and neither work.

@texalot As the Apple DKIM record is a ‘pointer’ (ending in “.com”), you need to create a CNAME record.

If the DKIM record had been a ‘key’ (starting with “v=DKIM”) you’d have created a TXT record instead.

If you are still experiencing issues, please provide your domain name and confirm the symptoms you are seeing now. 

Edited by paul2009

Me: I'm Paul, a SQSP user for >18 yrs & Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL. We provide high quality original extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is completely free. You can thank me by selecting a feedback emoji. Buying a coffee is generous but optional.

Link to comment
43 minutes ago, NadineS said:

Having the same issue.

@NadineS Please provide some more information, including the domain name and the issue you are experiencing. Also, what have you tried so far to resolve this? What is or isn’t working?

Me: I'm Paul, a SQSP user for >18 yrs & Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL. We provide high quality original extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is completely free. You can thank me by selecting a feedback emoji. Buying a coffee is generous but optional.

Link to comment
  • 1 month later...
  • 2 weeks later...
On 6/11/2023 at 11:44 AM, paul2009 said:

@texalot As the Apple DKIM record is ‘pointer’ (ending in “.com”), you need to create a CNAME record. If the DKIM record had been a ‘key’ (starting with “v=DKIM”) you’d have created a TXT record instead.

If you are still experiencing issues, please provide your domain name and confirm the symptoms you are seeing now. 

I am still experiencing these issues. please help!

 

Link to comment
On 6/11/2023 at 2:44 PM, paul2009 said:

@texalot As the Apple DKIM record is ‘pointer’ (ending in “.com”), you need to create a CNAME record. If the DKIM record had been a ‘key’ (starting with “v=DKIM”) you’d have created a TXT record instead.

If you are still experiencing issues, please provide your domain name and confirm the symptoms you are seeing now. 

Is the above really the whole solution to this problem?

 

Link to comment
On 6/11/2023 at 11:46 AM, paul2009 said:

@NadineS Please provide some more information, including the domain name and the issue you are experiencing. Also, what have you tried so far to resolve this? What is or isn’t working?

the domain name is "watchtowerinspections.ca" 

I have inputted all of the DNS information that apple gave me, and nothing seems to be happening. Apple wants me to input all my "existing" emails with my domain, but I dont have any existing ones. I just want to use Iclouds service where I dont have to pay SS 6$ a month just for a custom email as I am already paying apple. When ever I put my desired email in that section, I am unable to verify that email becase I dont have one through square apce yet. I have tried many times to verify both my icloud and @watchtowerinspections email and the furthest I will get is apple saying it may take up to 72 hours for the changes to take affect. Then nothing happens. Super frustrated. 

Link to comment
  • 3 weeks later...
  • 3 weeks later...
  • 3 weeks later...
  • 1 month later...
On 6/11/2023 at 1:44 PM, paul2009 said:

@texalot As the Apple DKIM record is ‘pointer’ (ending in “.com”), you need to create a CNAME record. If the DKIM record had been a ‘key’ (starting with “v=DKIM”) you’d have created a TXT record instead.

If you are still experiencing issues, please provide your domain name and confirm the symptoms you are seeing now. 

I'm still getting an error message 

Link to comment
  • 3 weeks later...
  • 3 weeks later...
On 6/11/2023 at 11:46 AM, paul2009 said:

@NadineS Please provide some more information, including the domain name and the issue you are experiencing. Also, what have you tried so far to resolve this? What is or isn’t working?

Happy New Year.  Thank you for all your help.  I enter in all of the records as Apple provided.  However, when I try to verify the that it works, it fails.  Here are my settings.

 

squarespace.GIF

Link to comment
  • 2 months later...

I'm available to guide you through the process of configuring Squarespace to work with iCloud+ , send an email with the subject "iCloud Squarespace Help" to: consulting@elicottle.com

Link to comment
  • 2 weeks later...
  • 2 months later...
  • 4 weeks later...

So no solve from Squarespace on this?

For me, it seems Squarespace does not like the "." punctuation at the end of an email server value for the MX records.

This is also reported on Apple's forums (https://discussions.apple.com/thread/254973529?sortBy=best) and another Squarespace forum thread:

I also had to configure another custom iCloud to a domain registered through  Gandi and they accept the "." punctuation at the end – setup took less than a minute.

Maybe the true solve is to transfer my domain to another service...

 

Screenshot2023-05-01at10_56_37AM.thumb.png.7df15d368f38fe70b9544ee06ac82403.png

Link to comment

Squarespace already sets the end punctuation for the MX records. If you run the following command (dig) in a terminal, you'll be able to see your records:

dig [example.com] MX

;; ANSWER SECTION:
example.com.		14400	IN	MX	10 mx01.mail.icloud.com.
example.com.		14400	IN	MX	10 mx02.mail.icloud.com.

Just replace [example.com] for your domain. In my case: dig timrodz.dev MX

The same can be done for any other records regarding your website. I've checked all of my records and they're properly set (the dig command has helped me confirm this), but iCloud is still saying I need to check my DKIM record.

 

I'm now going to try the following:

Host: sig1._domainkey

Type: TXT

Data: v=DKIM sig1.dkim.timrodz.dev.at.icloudmailadmin.com.

 

Will report back shortly.

Link to comment

Hey everyone I was able to solve this issue! Here's how I did it:

1. From the iCloud+ panel: Add your website WITHOUT www. In my case, I had www.timrodz.dev, and changed it to timrodz.dev

2. From the iCloud prompt you get after adding your site, add the records to your Squarespace domain. Here's how mine look:image.thumb.png.875bae4fc00ea122f57c7335a11ec296.png

3. Wait for propagation to finish by using the `dig [website.com] [record-name]` command I wrote about in my previous comment. In my case:

dig timrodz.dev MX

dig sig1._domainkey.timrodz.dev CNAME

If you get an ANSWER SECTION in both, verify the values match your Squarespace Domain's values, and you should be set.

4. Check again inside your iCloud setup, and hopefully you're sorted! From this point, if all is good, all you have to do is add the email domains on the iCloud website.

 

Good luck!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.