Jump to content

Apostrophe and Quote Marks Text Problem

Recommended Posts

When typing the word Let's Squarespace initially inserts the wrong apostrophe character and it looks like Let' s. To "fix" this I have to backspace and remove the apostrophe, add it again, then backspace again, and it looks right like Let's with the right character and no extra space. (See video).

The same thing happens with quotation marks.

What's going on with this? It does it for more than one font. Thanks.

Edited by SCAgency
Correction
Link to comment

Sounds like a bug, have you reported it to Squarespace Support?

https://support.squarespace.com/hc/en-us

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Yes, sadly I did. "Solutions" included trying another font. This is the client's identity font. Even when I did the same thing happened on other fonts.

The other "solution" was exactly what I did with backspacing. That's not a fix.

I got the standard, non-committal "We'll let our developers know about this and we *might, maybe someday* address this." I can't tell a client to backspace every time they use a punctuation mark. They don't know or don't care that I didn't program the Squarespace platform.

So I'm coming here because someone is smart enough to figure this out and instruct them how to fix it. This must be like the 3rd or 4th glitch with Squarespace I've found in the past few years that seems to stump their support staff.

I'm not sure if the apostrophe is initially being encoded as a prime mark instead or it's just failing to grab the right encoded character. I go into Inspector and am not sure how to drill down to actual HTML character it is using. Even if I could I'm not sure what is causing it to fail.

When I go to Adobe Fonts or any other site selling Futura PT, their apostrophe and quote marks work just fine. I have noticed a few other posts over the years here talking about various problems with apostrophes. I'm not sure if it is related or not.

So LET'S SOLVE THIS Squarespace heroes!

Thanks.

 

Edited by SCAgency
Link to comment

Thanks creedon.

I tried some javascript to replace curlies with straight. Maybe I didn' t use the right unicode characters (tried various ones for apostrophes and quote marks) or something, but no attempt worked in a code block or with code injection. Had Chat GPT write some code, but that didn't work as well.

It would be super helpful to know what failed, substitution unicode is being used for their ' and " marks. So far I can replicate it with Futura PT, Montserrat and Poppins, so likely many others are impacted. But I think you're right. Somewhere in SS code I think there is a conscious effort to prefer curlies.

Squarespace emailed back now after I showed them this on several sites in different browsers and different fonts and admitted there is an issue. Seems like it might be escalated a bit.

Super open to anyone's ideas on a javascript replace fix.

Edited by SCAgency
Updated info
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.