Jump to content

Hiding blog item meta wrapper on one of two blogs

Go to solution Solved by Ziggy,

Recommended Posts

Hi everyone, 

I'm working on a site that has two blogs (one that is used to display projects and one for blog posts/news/stories). 

I am trying to hide the blog item meta wrapper on the 'projects' blog only as they don't need to have 'author' and 'date' displayed. 

Can anyone else me with the code that will get rid of this? 

Thanks so much 🙂

Link to comment

Can you share your website URL?

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Hey @BritishDan, you should be able to switch this off in the page settings however you can target the meta data on the overall blog page with the below CSS
 

.blog-meta-section {

display: none;

}

or use this to target it within the individual posts
 

.blog-item-meta-wrapper {

display: none;

}

You can target a specific page by adding this code within <style> tags in the Page specific header injection.

Squarespace Developer based in Hampshire, England

If you'd like to make a contribution for my time you can Buy Me A Coffee.

Link to comment
47 minutes ago, abibacon said:

Hey @BritishDan, you should be able to switch this off in the page settings however you can target the meta data on the overall blog page with the below CSS
 

.blog-meta-section {

display: none;

}

or use this to target it within the individual posts
 

.blog-item-meta-wrapper {

display: none;

}

You can target a specific page by adding this code within <style> tags in the Page specific header injection.

Unfortunately, if I do it via the page settings, it switches the meta data off on the news pages too. 

The CSS doesn't seem to work for me 😞

Link to comment

I would try adding this code to the "Post Blog Item Code Injection" in the page settings "Advanced" to have it just effect the portfolio "blogs":

<style>
.blog-item-wrapper .blog-item-author-date-wrapper {
    display: none !important;
}
</style>

image.thumb.png.fc1f1ba30d168f10a3bf9bfc115b2721.png

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment
  • Solution

I've amended the code here:

<style>
.blog-item-wrapper .blog-item-author-date-wrapper, .blog-item-wrapper .blog-meta-item--categories {
    display: none !important;
}
</style>

 

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.