Jump to content

Images on my blog section won't show

Recommended Posts

Can you share your website URL? Thanks!

Please like and upvote if my comments were helpful to you. Cheers!

Zygmunt Spray
Squarespace Website Designer
Contact me: 
https://squarefortytwo.com 
Hire me on Upwork!

🔌 Ghost Squarespace Plugins (Referral link)
📈 SEO Space (Referral link)
 SquareWebsites Plugins (Referral link)
 🔲 SQSP Themes (Referral link) 
Spark Plugin (Referral link) 

 Did I help? Buy me a coffee?

Link to comment
On 3/9/2023 at 7:51 AM, AndreasOrntoft said:

I have a scrolling blog section on my home page, however the photos won't show the first time you enter the site or if you enter the site using incognito. Not sure what the problem is. 

Please report this issue to Squarespace. Some strange things are happening with the image focal points on your site. The focal point should contain two numbers between 0 and 1 but are shown as NaN ("not a number") or simply "," without any digits:

image.png.eb0836d8fa7fde9d0ca3d959d046b3c4.png

This is either happening because of custom code that you have added to the site, or because of a Squarespace bug, but it hasn't been reported by anyone else yet.

Did this help? Please give feedback by clicking an icon below  ⬇️

Edited by paul2009
edited for clarity

About me: I'm Paul. A SQSP User for 18 yrs, I joined Circle when it launched in 2016 and have been a Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL, providing expertise and extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is free. You can thank me by clicking one of the feedback emojis below. Coffee fuels my work.

Book paid help with a Squarespace Domain

Link to comment
18 minutes ago, AndreasOrntoft said:

However the support team claim that they fix it by disabling scripts in preview and that it is caused by custom code which they don't support. The thing is, that I don't believe it is caused by custom code.

You can test this for yourself by removing the custom code (save it somewhere safe!). Once removed, you can then test the site from an incognito window to see if the problem occurs.

If the problem remains with no custom code, you can go back to the support team and explain this.

If the problem goes away when the scripts have been removed, you'll know that the custom code is the issue. You can then add the code back in, one script at a time until the problem occurs again. Be sure to close all incognito windows before retesting. This should allow you to identify which script is causing the issue. 

Did this help? Please give feedback by clicking an icon below  ⬇️

About me: I'm Paul. A SQSP User for 18 yrs, I joined Circle when it launched in 2016 and have been a Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL, providing expertise and extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is free. You can thank me by clicking one of the feedback emojis below. Coffee fuels my work.

Book paid help with a Squarespace Domain

Link to comment
23 minutes ago, AndreasOrntoft said:

I have a cookiebot installed in the footer, and if I disable that, the issue disappears. It is very important that we have the cookiebot enabled, can we some how work around that?

If the cookie consent tool is causing the issue, you're probably using it to disable cookies that are essential for the site to run correctly. I recommend that you check that none of the functional and required cookies are being disabled in your tool's settings.

Did this help? Please give feedback by clicking an icon below  ⬇️

About me: I'm Paul. A SQSP User for 18 yrs, I joined Circle when it launched in 2016 and have been a Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL, providing expertise and extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is free. You can thank me by clicking one of the feedback emojis below. Coffee fuels my work.

Book paid help with a Squarespace Domain

Link to comment
  • 2 weeks later...

Hi again Paul. 

I have now been in contact with CookieBot, as I found out that it was my CookieBot causing the issue. The problem seems to be, that CookieBot somehow blocks the photos in the blog-carussel. The support from CookieBot asked me to put the CookieBot CMP Script first to load in the Head-section. I did that, but the supporter told me, that the script wasn't first to load but that it was placed as number 25. 

Do you know, how that can be? He also asked me to remove "defer" from the script below, however I can't seem to find the script in my head- or foot section... 

 

I think I found the culprit which is the defer attribute in the following script: <script defer="defer" src="https://static1.squarespace.com/static/vta/5c5a519771c10ba3470d8101/scripts/site-bundle.70f4ad0dab6e9e67e5f2e237b4b30098.js" type="text/javascript"></script>.
 
If you remove defer="defer" from the script, it should work as intended.

Link to comment
1 hour ago, AndreasOrntoft said:

CookieBot asked me to put the CookieBot CMP Script first to load in the Head-section. He also asked me to remove "defer" from the script below.

Sadly, you are being asked to change things over which you have no control on Squarespace. You cannot add code to the start of the head section (it will be inserted into a fixed position within the head section) and you cannot remove the defer attribute from Squarespace's own code.

Unless other forum users have suggestions, it sounds like you will need to speak to someone at CookieBot who knows Squarespace well (they'll have access to the account to troubleshoot this), or you may want to try a different cookie consent tool that is known to work well with Squarespace. Personally, I'd use CookieScript, but it will obviously depend on your requirements. 

Did this help? Please give feedback by clicking an icon below  ⬇️

About me: I'm Paul. A SQSP User for 18 yrs, I joined Circle when it launched in 2016 and have been a Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL, providing expertise and extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is free. You can thank me by clicking one of the feedback emojis below. Coffee fuels my work.

Book paid help with a Squarespace Domain

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.