Jump to content

Pictures not loading in gallery block - no errors/404

Recommended Posts

Hi all,

For a couple of weeks now I've had an issue on my site where half the galleries fail to load & display the images that I placed there. The other half of my galleries show perfectly and without problems; they use the same layout (grid: strips). There is no 404 or other error message, the images simply don't load and the captions sit there by themselves. When I select "Edit gallery", all images are there and show with no problems.

The link I've attached shows one of the pages with missing pictures; the "Antarctica" page, for example, shows with all pictures loading correctly.

Thanks in advance for any help or pointers!

Link to comment
  • Replies 9
  • Views 2.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I have the same issue.  I have been using the carousel for images and they won't load anymore.  I am trying to display the website on a digital display. The website looks fine on a computer or phone, but no images will load onto the digital display screen.  

 

Link to comment

Hello - don't know if it'll help anyone, but my issue was related to an <i> tag in a quote block in my header above the gallery that wasn't closed with a </i>. Adding the </i> resolved the issue immediately. Not sure why it became a problem suddenly after working fine for a year, but at least the mystery is solved! Page is jonfuhrmann.com.

Link to comment
On 1/18/2023 at 3:07 AM, jonostan said:

Not sure why it became a problem suddenly after working fine for a year

Browsers are able to muddle through some bad HTML and do the right thing. Probably what happened is that the overall structure of the document changed, SS is making tweaks all the time, and the browser was no longer able to muddle through.

Edited by creedon

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment
  • 10 months later...
On 12/15/2023 at 7:30 PM, daniel_moisan said:

Could you please help. I have a similar issue that just started yesterday. Gallery pages randomly half load and load twice like a flash. I have tested by removing all code blocks, code injection and CSS. Problem still persists. Thanks for your help. 

 

animalhausstudio.com/transistor 

Try removing this code from CSS box

image.png.b1e46f16a23aec95ddb9358bfd7ca26b.png

Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

Contact Customer Care - Learn CSS - Buy me a coffee (thank you!)

Link to comment
  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.