Jump to content

Embedded Script in Edit Mode Forces Spacing Issue

Go to solution Solved by Ziggy,

Recommended Posts

I upgraded my page to the new grid editing, and now the spacing for one of my embedded videos is not resolvable. A note stating "this block contains embedded scripts..." resides at the top of the video embed forcing the grid count on the section to be greater than necessary. There is a button to "preview in safe mode" which does nothing. I tried recreating the embed, but the issue persists. What gives?

SS - No Resolve for Edit to Live View.JPG

Link to comment
  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Posted Images

Embeds are tricky to deal with in the Fluid Engine grid editor. Typically you have to try and guess the size and match that in the grid. Embedded content with stretch the code block to fit, but isn't likely to be responsive so you just have to try and accommodate it the best you can and deal with the spacing.

Can you share your website URL and page so I can get a better idea of what's going on specifically for you?

(I'm not sure the "preview in safe mode button" has ever done anything for me)

Please like and upvote if my comments were useful to you. Thanks!

Zygmunt Spray
Squarespace Website Designer
Contact me: https://squarefortytwo.com/ 
🔌Ghost Squarespace Plugins (Referral link)
Buy me a coffee

Link to comment
2 hours ago, Ziggy said:

Embeds are tricky to deal with in the Fluid Engine grid editor. Typically you have to try and guess the size and match that in the grid. Embedded content with stretch the code block to fit, but isn't likely to be responsive so you just have to try and accommodate it the best you can and deal with the spacing.

Can you share your website URL and page so I can get a better idea of what's going on specifically for you?

(I'm not sure the "preview in safe mode button" has ever done anything for me)

Here's the URL

https://www.coorlasarch.com/residential/wilmette-home-addition

It worked fine before I updated the section to the fluid engine grid editor. It's like that warning during editing is preventing the grid height from being reduced. A bit frustrating.

Link to comment
25 minutes ago, CoorlasArchitecture said:

A bit frustrating.

Yes, I'm sure!

Once that grid has rows they don't disappear, with the old columns they were just the height that the content in them was. 

Can you share the embed code you're using, maybe I can find a technique to help you shrink the code block. (I'm guessing it won't drag any smaller than you currently have it?)

Please like and upvote if my comments were useful to you. Thanks!

Zygmunt Spray
Squarespace Website Designer
Contact me: https://squarefortytwo.com/ 
🔌Ghost Squarespace Plugins (Referral link)
Buy me a coffee

Link to comment
2 minutes ago, Ziggy said:

Yes, I'm sure!

Once that grid has rows they don't disappear, with the old columns they were just the height that the content in them was. 

Can you share the embed code you're using, maybe I can find a technique to help you shrink the code block. (I'm guessing it won't drag any smaller than you currently have it?)

Correct - it will not drag any smaller. It's like that 'warning' label at the top of the embed is preventing it from shrinking.

Here is the embed code:

<div style="padding:56.25% 0 0 0;position:relative;"><iframe src="https://player.vimeo.com/video/697084704?h=e655d88f72&autoplay=1&loop=1&title=0&byline=0&portrait=0&muted=1" style="position:absolute;top:0;left:0;width:100%;height:100%;" frameborder="0" allow="autoplay; fullscreen; picture-in-picture" allowfullscreen></iframe></div><script src="https://player.vimeo.com/api/player.js"></script>

 

Thanks for your input on this!

Link to comment
  • Solution

Can you try this Custom CSS to hide the warning message?

html.squarespace-damask .sqs-blockStatus {
    display: none !important;
}

It may only work when in the CSS panel, but if it does it will allow you to then go back into editing the page and shrink the block down.

Please like and upvote if my comments were useful to you. Thanks!

Zygmunt Spray
Squarespace Website Designer
Contact me: https://squarefortytwo.com/ 
🔌Ghost Squarespace Plugins (Referral link)
Buy me a coffee

Link to comment
On 1/3/2023 at 2:59 PM, Ziggy said:

Can you try this Custom CSS to hide the warning message?

html.squarespace-damask .sqs-blockStatus {
    display: none !important;
}

It may only work when in the CSS panel, but if it does it will allow you to then go back into editing the page and shrink the block down.

Yes! This worked. There is still a snippit at the bottom that reads "Script Disabled" which is preventing it from being minimized completely. But this worked to reduce the height. Thanks again for your input!

Script Disabled.JPG

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.