Jump to content

Can't Verify Domain via DNS Record with Google Search Console

Go to solution Solved by paul2009,

Recommended Posts

Hi everyone. I'm hoping someone can help me. I'm not the most savvy with websites, Squarespace has been good so far but I've run into a problem. 

I'm trying to verify my domain via DNS record on the Google Search Console. It says:

  • Select record type: TXT
  • Sign into your domain provider
  • copy the TXT record below into the DNS configuration for theclaytalk.com
 
So I went into the DNS settings in my Squarespace website. I created a custom record. The host is theclaytalk.com. Type is TXT. The Data is the string of text they told me to copy and paste. 
 
However, when I click verify in the google console it says "We couldn't find your verification token in your domain's TXT records. Sometimes DNS changes can take a while to appear. Please wait a few hours, then reopen your property in Search Console. If verification fails again, try adding a different DNS TXT record."
 
I've tried waiting 2 days now and it still won't verify. I'm not sure what I've done wrong. If anyone knows what to do I would greatly appreciate any help.
Cheers
Amanda
Link to comment
  • Solution
15 hours ago, TheClayTalk said:

I'm trying to verify my domain via DNS record. I went into the DNS settings in my Squarespace website. I created a custom record. However, when I click verify in the google console it says "We couldn't find your verification token in your domain's TXT records".

Hi Amanda

This is often a timing issue but not in this case. I checked the domain theclaytalk.com but no TXT records exist at the moment.

I recommend that you check your settings in the Domains panel and try to add the TXT record again. Do post a screenshot of the current settings if you are unsure how to proceed.

Did this help? Please give feedback by clicking an icon below  ⬇️

Me: I'm Paul, a SQSP user for >18 yrs & Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL. We provide high quality original extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is completely free. You can thank me by selecting a feedback emoji. Buying a coffee is generous but optional.

Link to comment
21 hours ago, paul2009 said:

Hi Amanda

This is often a timing issue but not in this case. I checked the domain theclaytalk.com but no TXT records exist at the moment.

I recommend that you check your settings in the Domains panel and try to add the TXT record again. Do post a screenshot of the current settings if you are unsure how to proceed.

Did this help? Please give feedback by clicking an icon below  ⬇️

Thanks, I tried adding the @ symbol instead of writing theclaytalk.com as the host. This seemed to fix it 🙂

Link to comment
3 minutes ago, TheClayTalk said:

I tried adding the @ symbol instead of writing theclaytalk.com as the host. This seemed to fix it

Yes, I can confirm the record exists now:

image.thumb.png.c2f64e3a8e82a16a69a2fdee9762ae13.png

Did this help? Please give feedback by clicking an icon below  ⬇️

Me: I'm Paul, a SQSP user for >18 yrs & Circle Leader since 2017. I value honesty, transparency, diversity and good design ♥.
Work: Founder of SF.DIGITAL. We provide high quality original extensions to supercharge your Squarespace website. 
Content: Views and opinions are my own. Links in my posts may refer to my own SF.DIGITAL products or may be affiliate links.
Forum advice is completely free. You can thank me by selecting a feedback emoji. Buying a coffee is generous but optional.

Link to comment
  • 10 months later...

Same exact problem for me. Need to fix this because emails keep bouncing for certain segments of our audience with filters or high security.

Tried '@' instead of google host/TXT name, and it isn't working for me... at least checking immediately. Perhaps need to wait 48hrs. Not ideal to have to wait that long over and over to fix this. See attached. Thanks for any advice out there!

 

Screenshot 2023-10-16 at 11.13.00 AM.png

Screenshot 2023-10-16 at 11.14.18 AM.png

Screenshot 2023-10-16 at 11.16.43 AM.png

Link to comment
  • 5 months later...
On 10/16/2023 at 2:19 PM, mrjessewalker said:

Same exact problem for me. Need to fix this because emails keep bouncing for certain segments of our audience with filters or high security.

Tried '@' instead of google host/TXT name, and it isn't working for me... at least checking immediately. Perhaps need to wait 48hrs. Not ideal to have to wait that long over and over to fix this. See attached. Thanks for any advice out there!

 

Screenshot 2023-10-16 at 11.13.00 AM.png

Screenshot 2023-10-16 at 11.14.18 AM.png

Screenshot 2023-10-16 at 11.16.43 AM.png

 

Link to comment
  • 2 months later...
  • 2 weeks later...

Same here! I've added "txt", it seems my domain is verified now but it didn't solve the problem. My site is still not shown on Google after more than a year of using Squarespace. This is frustrating. 

Apparently I need to manually edit the "robots.tx" from "disallow" to "allow" but how to do that? It seems i don't have access. 

I hope there is a solution, I'd appreciate any advice. Thank you!


image.thumb.png.8402635a623b6fcfd6db311cae0b6958.png

Link to comment

Hi @Elena185 the screenshot above shows the default Squarespace robots.txt file for every site. Any issues with visibility would not be related to this file. 

Have SEO questions? Chances are we've written about it! Try a quick Google search to find our advice. Or for personalized support, see our consulting and training sessions.  Official Squarespace Experts since 2014 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.