Jump to content

Website not loading unless I have www in the URL

Recommended Posts

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

16 hours ago, tuanphan said:

It loads fine to me for non-www

If you are checking in the browser then it will try variations on the base address you enter to try and get to an address. This all happens out of site.

So what is happening when you enter an address is the browser first trying the one you enter. wildandwhimsy.co.uk. When it gets a fail on that it tries www.wildandwhimsy.co.uk and so forth. The browser basically tries all the likely possibilities, all out of site.

Not sure all browsers do this but the big ones do.

Using a command line tool like curl with wildandwhimsy.co.uk you get no response. But with www.wildandwhimsy.co.uk you do.

@VanessaWhimsy

This indicates to me that you've not set up a wildcard record that tells your domain what to do when hitting just the base domain name. In most cases that is to hit the www dns record.

This is an issue you need to take up with your domain registrar as it has nothing to do with your SS site, i.e. there no SS settings that will magically fix things. I took a quick look at your registrars docs but they were mostly cryptic and unhelpful. Not surprising. It takes a lot of effort to write quality helpful docs for those that aren't tech heads.

Edited by creedon

Find my contributions useful? Please like, upvote, mark my answer as best , and see my profile. Thanks for your support!

Link to comment
14 hours ago, VanessaWhimsy said:

For some reason the website only loads if it has www in front of the domain name. Any ideas?

By default, your site should work correctly with or without the "www" subdomain. It does for me 🙂

As @creedon said, if a user types the domain name into their browser without the "www" it should automatically redirect to www.wildandwhimsy.co.uk. This is by design.

If you don't want the "www" to appear,  you can disable this as follows:

  1. In Squarespace, go to Settings > Domains.
  2. In the DOMAINS MANAGED BY THIRD-PARTY section, click your domain name. It should have a 'PRIMARY' label.
  3. In the panel that appears on the right, uncheck Use www prefix.

         image.thumb.png.9d37e5eeb6e252a71b7372640bdc546f.png

 Did this help? Please give feedback by clicking an icon below  ⬇️

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.