Jump to content

All emails sent from my contact form go to my spam folder

Recommended Posts

So as the title says, all customer inquiries sent from my sites contact page go to my spam folder.  Because my phone does not deliver spam notifications (nor does my computer), I miss many emails and only see them if I go to check spam, which I never do from my phone.  I use gmail with a workspace account, so emails are sent to contact@mydomain.com and not gmail.com.  I have looked through all settings in gmail and cannot find anything to correct this.  Google support has been utterly useless any time I have tried to use them, so hoping someone can help here.

Link to comment
  • 4 weeks later...
  • Replies 2
  • Views 429
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

I don't have a solution but one tip.

If you're using Gmail then when an email ends up in the SPAM folder, G has options to mark the email as not SPAM.

macOS Mail has a similar feature as I suspect other emails apps do as well.

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.