Jump to content

Editor keeps jumping to top of page

Recommended Posts

Site URL: https://purple-ladybug-se73.squarespace.com

Hi there!

 

Every time I try to do any kind of edit, add text, resize text, etc. it’s jumps from what I’m doing back to the top of the page in the editor. It’s really annoying and severely impacting my workflow. I’ll get 2-3 letters typed then it will jump, I then have to scroll back to where I was and type another few letters. Does anyone know what’s causing this or how to fix it? 

Link to comment
  • 5 weeks later...
  • Replies 17
  • Views 5.3k
  • Created
  • Last Reply

Top Posters In This Topic

  • 3 months later...
  • 2 weeks later...
3 minutes ago, SamKahn said:

i have the same issue and its extremely annoying. what would take me 30mins is already taking me a few hours and my patience is growing thin.. if anybody has a solution...

 

So, for some reason changing from safari to chrome did the trick. For now at least.

Link to comment
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 3 months later...

Literally just made a forums account (unfortunately) JUST to add yet another response almost a whole YEAR later just to say I am also experiencing this problem and it makes square space virtually impossible to actually use. I just bought a whole year's subscription upfront and I am already experiencing infuriating problems. (I should've went with Wix, never again square space)

As SOON as I type ONE single character, or drag a text box or button ANYWHERE, the page instantly jumps to the top of the website and de-selects whatever I was working on or typing in, leaving me to scroll several screens back down to whatever I was trying to work on or add, re-select it, and try to type another character (if it doesn't instantly jump back to the top of the page again before I can even type anything).

I don't know how square space is as seemingly well-established as they are with such a broken and frustrating system. I feel that it's not very realistic to expect users to go and download a second browser to switch to just to be able to edit my own square space website. I do not recommend square space to anyone until they actually do something about this... which from the looks of it isn't happening anytime soon since the first person having this problem posted almost 12 months ago.

Happening on Safari version 15.6.1 and a 16-inch MacBook Pro running version 12.5.1.

PLEASE FIX THIS.

Edited by CDJ
Link to comment
  • 1 month later...

Has anyone fixed this? Also having the same issue on a Macbook. Issues with both Safari & Chrome.

Have sent a message to Squarespace.  They don't seem to be 'aware' of it and have said they are actively looking into it, although that said - it has been 3 weeks and there has not been a solution.

Interested in any tips or tricks to get through this.

Thanks!

Link to comment
  • 1 month later...

Yesterday my site began having this terrible behavior.   When I go to edit any page the editor keeps scrolling back up to the top.  Meaning that if I click to edit a section and try to add or move or edit anything (even in the footer) as soon as I click, the editor window fast scrolls to the top of that page.  It take numerous takes to do something simple like edit a text block or add an image block because the instant scroll to the very top of the page either moves what I was attempting to move some random place, or does nothing but just scroll and "forget" what I was doing.  Is this a recent bug after the recent update?  It just started happening after the Refresh announcement.  

Link to comment

Did you figure it out? I've been struggling with this as well, and I contacted customer support and they said its because I have custom CSS on my site. However, I've had custom CSS since last year and didn't have the editing problem, so I have no clue what changed...

Link to comment
  • 2 weeks later...

I figured it out everyone. It  has to do with the custom CSS on your page. I how solved this was temporarily copying all my custom code and pasting it into a blank document, then deleting it within Squarespace. Then go ahead with all editing, then paste back in the custom code. This is the best solution I could find. 

Link to comment
  • 4 months later...
On 10/16/2023 at 11:17 AM, readmetxt said:

I figured it out everyone. It  has to do with the custom CSS on your page. I how solved this was temporarily copying all my custom code and pasting it into a blank document, then deleting it within Squarespace. Then go ahead with all editing, then paste back in the custom code. This is the best solution I could find. 

This is interesting because I just posted this same behavior I'm having now on Chrome and I'm sure the circle member tried but there was no answer for this and I just gave up and told him not to worry about it.  I tried your suggestion but it didn't work for me but what I am going to do is the opposite.  I'm going to just copy out the markup and paste it, edit it there, and then paste it back in.  Thanks for the idea.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.