Jump to content

My blog post are not being indexed by google.

Recommended Posts

Site URL: https://www.bobbymillette.com/

Hi,

It seems that most of my blog post are not being indexed by google. I have submitted my sitemap and I have also submitted each page manually. I talked to two squarespace support agents and they basically just pointed me to an article that doesn't help. My pages are all set to public and there is no code injected on the site that would set it to no index. I would contact google but it's almost impossible to reach a real person. Anyone know what could be going on?

Screen Shot 2022-06-13 at 9.43.19 PM.png

Link to comment

I'm not having much luck with this sort of thing either. I agree too with difficulty in trying to find real person to ask anything of...and not just being directed to irrelevant info.

sorry, no answer for you, just another question...

"Connect your Google Search Console account

The Search keywords panel shows how visitors locate your site. Connect and verify your site in this panel and return later to review the data:

  1. In the Home menu, click Analytics.
  2. Click Search keywords.
  3. Click Connect in the panel's pop-up...."

what pop-up saying connect?
there is none...

Does anyone know what I need to do?

Alison

Link to comment

This is a problem that Squarespace needs to address. I have at least 6 blogs that haven’t been indexed since March. I’ve requested that they be indexed and taken all of the proper steps to have them indexed, but there is still something keeping them in the “discovered, not indexed” status, while I have WordPress blogs created more recently have been indexed without issue. 

Link to comment
  • 3 weeks later...

As painful as it is, have you tried manually requesting an index?

image.png.8447996d497df179185bf9fc46e09ac2.png

 

FWIW, I too am in struggleville on this matter:

 

image.png.674ba85d1e91f0c4737d1eb1e4270ea2.png

 

I'm trying to manually request index for a week and see if this makes any significant difference.

Good luck to all, looks like we're on our own on this one.

Link to comment
  • 1 month later...

Exact same issue here. I moved two sites from WordPress and what a mistake. Blogging is a key component of my SEO strategy and on Squarespace, NONE of my blog posts appear at all in Google. The site pages do -- even the blog homepage. But none of the individual posts. Somewhat shocking really.

Link to comment
  • 1 month later...
  • 3 weeks later...
On 11/27/2022 at 4:02 AM, triple6 said:

Has anyone found an issue for this? I'm getting the same errors and seeing that only my homepage is being indexed, nothing else, and primarily no blog articles, which is the purpose of my entire site.

Something must have changed from Squarespace's side in the last few weeks, seems like my new blog posts are getting indexed without any issues now....

Link to comment
  • 1 month later...

I'm also having the same problem for my blog posts not being indexed. I've tried manually pushing it from SS settings to GSC and that doesn't work.

Additionally, my homepage will not be indexed by google because of a "soft404" I've tried adding content, etc. There's actually a lot of content. 

From other forums It seems like a few other people have had this same problem when they shifted from 7.0-7.1 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.