Jump to content

iframe makes menu not beeing loaded

Recommended Posts

Site URL: https://rose-gecko-jhss.squarespace.com/driving-directions?noredirect

Hi
on our website I have a programmed an interactive directions page that I implemented into squarespace as an iframe

<iframe width="100%" height="900px" frameborder="0" allowfullscreen src="https://mwmap.piespace.de/">

When I initially put the iframe in, everything is fine but when I reload the page, the menu disappears. Here the site with just with the iframe https://rose-gecko-jhss.squarespace.com/new-page-1?noredirect
When I look at the page source, the code for the menu seems to be completely missing. As an awkward workaround, for now I added the code for the menu from a working side into the code section in the pages advanced options. This works but also results in styling issues (mobile view) (seems to be triggered by a script).
https://rose-gecko-jhss.squarespace.com/driving-directions?noredirect

From comparing to page sources with and without the iframe, it seems like two scripts don't get loaded (see https://rose-gecko-jhss.squarespace.com/new-page-1?noredirect vs https://rose-gecko-jhss.squarespace.com/new-page2?noredirect)


Does anyone have an idea, how to fix the issue and get the native menu back?

Edited by Hedaja
fixed link
Link to comment
  • Replies 1
  • Views 133
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.