Jump to content

YouTube embeds either show a white square or they just spin when hitting play

Recommended Posts

Site URL: http://www.scottsimmons.tv/work/music-videos

I have created a site with a lot of YouTube embeds for my work. It's been published but once visiting the site both on desktop and mobile most all of the videos won't play (the Vimeo embeds seem to work better).

The YouTube embeds will be either just white, turn to white when hitting play or they will just spin with the loading circle going around and around. 

On a mobile browser, multiple ones, they all turn white when hitting play so can't do anything there. On desktop I can hit the play button again as it's spinning and it'll play. 

This is a on a fast, one gig internet connection. I've tried to copy/paste new YouTube URLs, still the same thing. 

This is literally the only reason I went with SquareSpace was I thought it could handle YouTube embed.  😭

Link to comment
  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Squarespace should handle YouTube videos well, but I see that isn't the case here. I have a couple of questions about how you embedded these:

Did you use a Video Block, Embed Block or a Code Block?

Did you use the youtu.be url or an embed code?

 

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.