Jump to content

Embedded form not showing up in certain browsers/browsing modes

Recommended Posts

Site URL: https://poweronwithlimbloss.org/discover-conference/#register-here

Hello! I am new to the forum. I offer site support to a nonprofit. We created a custom form for an event sign-up in the user's CRM Keap and it turns out that it's not visible in certain browsers or browsing modes. Has anyone encountered this before or have a solution? I feel like I am being hot potatoed with support and the event is 2 weeks away.

Thanks!

Link to comment
  • Replies 3
  • Views 426
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • 4 weeks later...

First let me say that I'm sorry I didn't see this in time and even more sorry that I don't have a good answer. I did a little digging and there's definitely something weird going on. For me, it loaded correctly in Firefox, Edge, and Chrome-Incognito.

I did find that the iframe src loads correctly in it's own chrome tab, (https://keap.app/contact-us/3728073293895876) but not inside the iframe.  As a work around, you could put in a button and link it to the above form. Not great, but it would work.

There also seem to be some 0px in height styles that are collapsing the iframe. This might be by design and are "opened up" via JavaScript. By manually expanding them, I eventually saw this:

image.png.65828eaceb2722218c612946df31b9b1.png

infusiosoft is keap's old name. My first thoughts are that there's some sort of cross-site scripting thing that  Chrome is shutting down, or some cookie that isn't responding correctly to one of the JavaScripts. But that's getting out of my area of expertise.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.