Jump to content

Recaptcha is not showing

Recommended Posts

Site URL: http://www.iamchristiankasper.com

Hello, 

I receive recently a lot of spam and random email addresses are being added to my newsletter list. Therefor I want to use a reCAPTCHA. But the integration is not working. In the edit mode it shows the reCAPTCHA and it doesn't mention any errors (e.g. "error for site owner: invalid site key" or domain errors)

But when I go to my site, scroll down to the footer and add a email address inside of the newsletter form it didn't show the reCAPTCHA. 

Anyone knows what the issue is? 

Screenshot 2022-03-01 at 18.45.54.png

Link to comment
On 3/2/2022 at 12:51 AM, ChristianKasper said:

I want to use a reCAPTCHA. In the edit mode it shows the reCAPTCHA. But when I go to my site...it didn't show the reCAPTCHA. 

Check your settings in Google to see that you have added both domains.

If the reCAPTCHA only appears when you are logged on (or viewing the site using the built-in Squarespace domain (the one that ends with .squarespace.com) then it is likely that you only added this domain to the Google settings. In this case, add the primary/public domain name too and save your settings. When you refresh your site, it should work.

Did this help? Please give feedback by clicking an icon below  ⬇️

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment
9 hours ago, paul2009 said:

Check your settings in Google to see that you have added both domains.

If the reCAPTCHA only appears when you are logged on (or viewing the site using the built-in Squarespace domain (the one that ends with .squarespace.com) then it is likely that you only added this domain to the Google settings. In this case, add the primary/public domain name too and save your settings. When you refresh your site, it should work.

Did this help? Please give feedback by clicking an icon below  ⬇️

thank you Paul. 

I added the squarespace domain (mauve-burgundy-2smd.squarespace.com/) , my primary domain (iamchristiankasper.com/) and the secondary which will expire in September (christiankasper.org/) . 

Any other idea why this might be the case? 

Link to comment

Have you removed the reCAPTCHA? I don't see it.

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment

I don't see the reCAPTCHA on the page or in the code -  even on the squarespace domain - so it's difficult to diagnose from here.

If it is still enabled (as shown in your original screenshot) you may want to contact Squarespace Customer Care as they may be able to see more with their access.

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment
  • 5 weeks later...
20 hours ago, nathan said:

@ChristianKasperany resolution to this? I'm having a similar problem. Setting up the form works fine, but when I visit from any of the domains added to my reCAPTCHA dashboard, I get ERROR for site owner: Invalid key type.

Hopefully you've found a fix?

Answering myself…

Turns out I was using keys for reCAPTCHA v3, which are not supported by Squarespace. (Explained in Troubleshooting section here: https://support.squarespace.com/hc/en-us/articles/115013193528#toc-troubleshooting).

Created v2 keys in my reCAPTCHA console and it is working now.

Link to comment
  • 3 months later...

After about an hour scouring the internet and delving into Google Developer pages way above my pay grade...

The answer for me was that I needed to use my SquareSpace "built-in domain" instead of the domain name I registered. So dont use your fancy domain like www.ilovecats.com  - just use the random website name that SquareSpace gave you when you started building the site. It's available under "Settings_Domains" and it's the "built-in domain."

Godspeed Squarespacers!

 

Link to comment
1 hour ago, JMastrangelo said:

The answer for me was that I needed to use my SquareSpace "built-in domain" instead of the domain name I registered.

You'll need to add both to the settings:

  • the built-in Squarespace domain is required whilst you are logged on to the site
  • the primary domain name is required for visitors

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.