Jump to content

Google Indexing Redirect Error

Recommended Posts

Site URL: https://www.pacificestimating.com.au/

Hi there,


I recently created my page on Squarespace using standard formats and tools.


I submitted the request to Google to index the site, however it continues to return a redirect error. I am using a custom domain provided by Squarespace. The only links I have are internal links to other pages within my site and they are all working fine. I do not know what the problem is and really need some help sorting this out so I can start my business. I have no idea why there are two affected pages. I only have one URL.

Please help.



Link to comment
  • Replies 6
  • Views 4.6k
  • Created
  • Last Reply

Top Posters In This Topic

Hi @kylescully27 - what date did you connect the custom domain to your Squarespace account and publish your website?

If you connected the domain and published recently (like in the last few days) then the results you're seeing in Search Console are just outdated and will change the next time Googles bots crawl your site. You can see in the second screenshot you shared that the two variations of the homepage URL were last crawled on Feb 9 and Feb 16.

You can help the process along by uploading your sitemap to Search Console and using the Request Indexing feature to nudge Google to recrawl the homepage if there have been changes since the Feb 16 crawl.

- Ed


Blue Hills Digital
Support with website optimization, SEO and finding a digital marketing strategy that works.

Latest resource: Squarespace SEO Services

Link to comment

Hi, Ed, I originally create the page around the 5th of February. I am continuously trying to update the page and fix this unknown error while resubmitting index request to google search console. This is still not working.

I just found that the sitemap generated through the squarespace domain is different to the sitemap generated through the custom domain. Mainly this refers to my page URL's (URL slugs) which I have recent simplified to try and fix this issue.




See snapshot from the second page...


Which should read



Bing told me I have a html name that is too long. Could it be that my image names could be too long?


Another issue could be:

The prefix HTTPS can be crawled, but all HTTP prefix's have the error. I don't understand how this can be an issue with Squarespaces simple drag and drop design.








Link to comment

Those two screenshots you shared look good to me - that's what you would want to see.

The first one shows Google has not only discovered and crawled, but actually indexed the correct version of your homepage URL: https://www.pacificestimating.com.au/

The second screenshot is for the insecure http version of the homepage, so you don't want Google to index that URL. Just make sure that if a user hits the http version they are redirected to the https version successfully. If not, make sure "secure" and "HSTS secure" are toggled on in Squarespace > Settings > Advanced > SSL.


Blue Hills Digital
Support with website optimization, SEO and finding a digital marketing strategy that works.

Latest resource: Squarespace SEO Services

Link to comment
  • 8 months later...

Hi, Ed!  I'm having the same issues as Kyle Scully with the "redirect error" (all of my redirects are internal as well).  My SSL has always been secured (and HSTS secured) per your recommendation above, but I'm still having index errors and the "http" pages are listed.  Is there another fix for this?

Also, you recommended having the page automatically transfer from the http to https, how do I do this?

Thank you and hope to hear from you soon.

Indexing issue.jpg

Link to comment
  • 10 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.