Jump to content

modal pop up appearing under content

Recommended Posts

Site URL: https://www.confusiontoclaritynow.com/arise

There are 6 buttons on my page: https://www.confusiontoclaritynow.com/arise

connected to a pop-up modal form in Convertkit. All of them except the first one started to show UNDER the content when I changed the destination code 2 weeks ago. The buttons had worked perfectly before that for 2.5 years.

What changed in Squarespace to make that happen and how can it be fixed?

I have worked with Convertkit support on this and they added code to try to make it work but determined that the problem is that since their CSS code does not fix the issue then that means the content section of that is operating on a different div plain in my website and therefore has its own z-index values. That means their CK values will not operate on that div plain and I need to reach out to the developer of the theme or to the developer of the plugin that is appearing on top of the form- and SQ support won’t help me.1110926796_ScreenShot2022-02-14at2_04_45PM.thumb.png.f61be77a8462c67b45f5c1b93cbe7407.png

Link to comment
  • Replies 8
  • Views 906
  • Created
  • Last Reply

Top Posters In This Topic

  • 6 months later...
On 2/22/2022 at 3:58 AM, tuanphan said:

Try adding to Design > Custom CSS

section#new-page-95 {
    z-index: 999;
}

 

Any luck with this @HelenaK?? I'm having the same problem on my site (https://www.sundayschoolwine.com/

@tuanphan I tried that code, and it's still doing. And same as Helena, both ConvertKit and SS are pointing to each other and don't have solutions. : (  Any other ideas? 

Link to comment
On 9/8/2022 at 2:25 AM, mallorycs said:

Any luck with this @HelenaK?? I'm having the same problem on my site (https://www.sundayschoolwine.com/

@tuanphan I tried that code, and it's still doing. And same as Helena, both ConvertKit and SS are pointing to each other and don't have solutions. : (  Any other ideas? 

That code works for Helena only (it contains section ID, each site, each section will have different id.

I don't see popup. Can you share link to exact page/or how to open popup on your site?

Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

Contact Customer Care - Learn CSS - Buy me a coffee (thank you!)

Link to comment
On 9/10/2022 at 6:03 AM, mallorycs said:

@tuanphan Added it back into homepage. Should show up after 10% scroll.

Try adding this to Design > Custom CSS

[data-section-id="63112231e9df127b525d0579"] {
    z-index: 99999;
}

 

Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

Contact Customer Care - Learn CSS - Buy me a coffee (thank you!)

Link to comment
On 9/12/2022 at 2:14 AM, mallorycs said:

@tuanphan Wow thank you!!! That worked. Only thing is, it is not working with my navigation links. Still showing up underneath them (see pic). 

Screen Shot 2022-09-11 at 12.12.23 PM.png

Can you enable popup? We will check it again

Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

Contact Customer Care - Learn CSS - Buy me a coffee (thank you!)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.