Jump to content

"ERROR SAVING" - "An error occurred while duplicating this item" on all blog collections

Go to solution Solved by tech_help_TX,

Recommended Posts


I have three blog collections on my website, hosted by Squarespace.

Two are written blog collections, and one is a Podcast collection.

For the past two years, I have been able to successfully click "edit" on any post in any of the three collections, and select "duplicate" at the bottom of the dialog box that appears, and use the subsequently duplicated post as a template for a new post.

This has saved time in publishing content to my site.

Last week, I started receiving an error.  Whenever I click "duplicate" on any post in any of the collections, I get this message:


"An error occurred while duplicating this item"

My two written blog collections have 93 items, each, and my podcast collection has 96 items.

I have attached a screenshot of the error message.  I have also started a support ticket with Squarespace support.

I hope to resolve this error soon, as it significantly impacts my workflow.

Has anyone run across this error?



Link to comment

I have been conversing with Squarespace support, and I figured I would update this thread with their responses, and maybe it will help others.

The initial support guy had me check my browser settings, clear my cache, etc.  I knew it wasn't on my end though.  He escalated the ticket and I received this response yesterday:


My name is Jason and I'm a Product Specialist here at Squarespace. I'm following up on an issue you were seeing with your posts and specifically with duplicating these.
Thank you for reporting this. I can confirm this is related to an issue with duplicating posts on our end. We’ve reported this to our Engineering team, and they’re currently prioritizing the issue.
For the time being you will want to create new posts rather than duplicate these.
Please keep in mind that there are many moving parts we need to address before we roll out a solution. We thoroughly test all fixes before they’re released.
As a result, we can’t guarantee how long it will take to fix issues like the one affecting your site. Also, because of the volume of reports we receive, we can’t always follow up personally when the issue is resolved.
That being said, customer bug reports are an important part of how we continue to improve our platform. If you come across any other unusual behavior, please let us know.

As of tonight, it is still not working.  Will update if/when there are updates.

Hope this helps people...

Link to comment
8 hours ago, derricksrandomviews said:

I cannot figure out why you cannot duplicate a post. It is a Squarespace error but  doesn't appear to be  system wide..  I am able to duplicate a post  both with 7.0 and 7.1. Are you using custom css in your blog page or some other custom feature?


Thank you for your interest in my issue. To test if my particular blog(s) or podcast collections were the issue, I created a completely new blog collection with a dummy post and that post was also not able to be duplicated.

So far, the issue remains.  Really weird, because as I said - I have used these blogs and podcast collections for 2 years on my website, publishing weekly posts by duplicating and using previous posts as templates.  

My best guess is that it is an internal server-side cache issue on Squarespace's end.  I don't know.  I hope it is fixed soon.

Link to comment
3 hours ago, derricksrandomviews said:

What template are you using? I have seen quirky errors  attached to one template or template family. 

The Template is called "Five." Was working fine for years, until 7 days ago.

Kind of weird.  Just checked if the issue is resolved... not yet.  I am in the middle of content creation right now. The issue is causing me significant man-hours.  However, the fact that Squarespace recognized that the issue is on their end does give me some hope that they will find a solution.

Thanks again.

Edited by tech_help_TX
Link to comment
4 hours ago, derricksrandomviews said:

I started a "Five" site this morning. I was able to duplicate the default blog posts without issue. I did not make one of my own but will try that as well. I do have a suggestion. Create a new blog page in the unlinked section of your site and see if you can duplicate a post there. Let me know what happens. 

I did that as one of my initial troubleshooting steps and it did not work. Super weird, I know.

Link to comment

Just to update -

Squarespace support has indicated they are also having an issue with duplicating pages, not just items in collections like blogs.

They have informed me that page duplication is now working.  I tested and confirmed that it is.

However, blog post / podcast post / collection item duplication is still not working.  So, the original problem is still not fixed.  Pretty crazy.

Will update....

Link to comment
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.