Jump to content

Edit and Published font are not the Same

Recommended Posts

Site URL: https://www.airstute.com/

I have chosen Poppin as the font for my site and it looks great when in the editing mode, though when I publish the site the font displayed is definitely not Poppins, it more like a Serif style. I've tried viewing the site in different browsers and changing then resaving the Poppin Font all to no avail. Any support would be greatly appreciated.

Link to comment
  • Replies 6
  • Views 425
  • Created
  • Last Reply

Top Posters In This Topic

Hi Tuanphan, thanks for your response. It doesn't appear that way to me. I too am viewing on Windows/Chtome

Even though I set Poppins as the font style, see this serif type font on at the web url....

image.thumb.png.dcad6e94353bb55a04782660fcf919c5.png

However when  editing I see the real Poppins Fonts.

image.thumb.png.da5eafafd1a884bb70b38ec4db71e35c.png

Link to comment

Still same here,

try adding this to Settings > Advanced > Code Injection > Header >> Then save & check again

(If you use Personal Plan >> Edit Site Footer >> Add a Code Block >> paste the code)

<link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?family=Poppins:ital,wght@0,300;0,400;0,500;1,300&display=swap" rel="stylesheet">

 

Edited by tuanphan

Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

Contact Customer Care - Learn CSS - Buy me a coffee (thank you!)

Link to comment
On 12/29/2021 at 8:03 PM, tuanphan said:

Still same here,

try adding this to Settings > Advanced > Code Injection > Header >> Then save & check again

(If you use Personal Plan >> Edit Site Footer >> Add a Code Block >> paste the code)

<link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?family=Poppins:ital,wght@0,300;0,400;0,500;1,300&display=swap" rel="stylesheet">

 

Hey Tuanphan, thanks for the code. I've added it as you've suggested though unfortunately still no joy.

Link to comment
19 hours ago, jadam said:

Hey Tuanphan, it would appear that this is now fixed. It may have taken a few minutes to take effect. Are you able to explain what the code injection is and why it was required? Thank you!

I guess Squarespace didn't load the font file properly. The code will load the Poppin font file from Google Font Library.

Email me if you have need any help (free, of course.). Answer within 24 hours. 
Or send to forum message

Contact Customer Care - Learn CSS - Buy me a coffee (thank you!)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.