Jump to content

Squarespace 7.1 - Summary Block: minimum 2 items per row on mobile

Go to solution Solved by Beyondspace,

Recommended Posts

My testing result

image.png.b1d3c5e3a7ee05190399505d512a7a37.png

BeyondSpace - Squarespace Website Developer

🖼️ Lightbox Studio (Enable Pinch/Zoom on lightbox)
🗓️ Delivery Date Picker (Squarespace Date picker form field)
💫 Gallery block 7.1 workaround
🥳 Sparkplugin Customisations Browsers (Browse +100 Spark plugin customisations)
🥳 Elfsight Template Browsers (Browse +1000 Elfsight widget Templates)

If you find my answer useful, let's leave a like or upvote so others with the same issue can find their solution. Thank you!

 

Link to comment
3 hours ago, bangank36 said:

 

Hi,

You can try adding to Home > Design > Custom Css

/*Setting 2 item in 1 row summary block on mobile*/
@media only screen and (max-width: 767px) {
  #block-yui_3_17_2_1_1636734918137_160690 .summary-item {
    width: 50% !important;
    display: inline-block;
    float: right;
  }
}

Let me know how it works on your site

Press 👍 or mark this answer as solution to help another one too

 

The code works well only with even number of items.

But with odd number of items, not perfect. For some reason { float: left; } doesn't fix it.

Any way to fix it?

IMG_0101.PNG.85e0439da85e42e0780c379e3bd9302b.PNG

 

 

 

 

Found another bug:

Between 675px and 767px wide, the layout is all messed up:

1916216066_ScreenShot2021-11-21at12_31_43.thumb.png.a29636d2d4e3fc2480ae014a152dd0e2.png

Edited by alanx
Link to comment
1 hour ago, bangank36 said:

Hi,

Kindly replace my previous codes with the following ones

@media only screen and (max-width: 767px) {
  .summary-item-list {
    display: flex;
    flex-wrap: wrap;
  }

  .summary-item {
    width: 50% !important;
  }
}

 

 

Unfortunately, between 675px and 767px wide, the layout is still messed up. Anyway to fix it? Thanks.

Link to comment
  • Solution
8 hours ago, alanx said:

 

Unfortunately, between 675px and 767px wide, the layout is still messed up. Anyway to fix it? Thanks.

Hi @alanx,

I suggest another solution with grid. Try the following code on your site

@media only screen and (max-width: 767px) {
.summary-item-list {
  display: grid;
  grid-template-columns: 1fr 1fr;
}
  .summary-item {
  width: 100% !important;
  }
}

Let me know how it works on your site

Press 👍 or mark this answer as solution to help another one too

BeyondSpace - Squarespace Website Developer

🖼️ Lightbox Studio (Enable Pinch/Zoom on lightbox)
🗓️ Delivery Date Picker (Squarespace Date picker form field)
💫 Gallery block 7.1 workaround
🥳 Sparkplugin Customisations Browsers (Browse +100 Spark plugin customisations)
🥳 Elfsight Template Browsers (Browse +1000 Elfsight widget Templates)

If you find my answer useful, let's leave a like or upvote so others with the same issue can find their solution. Thank you!

 

Link to comment
3 hours ago, bangank36 said:

Hi @alanx,

I suggest another solution with grid. Try the following code on your site

@media only screen and (max-width: 767px) {
.summary-item-list {
  display: grid;
  grid-template-columns: 1fr 1fr;
}
  .summary-item {
  width: 100% !important;
  }
}

Let me know how it works on your site

Press 👍 or mark this answer as solution to help another one too

 

Thank you, this works!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.